Download

Emissive Light doesn't work, man...

See attached. I’ve followed a ton of guides, but for some reason this just doesn’t work for me. I’ve even read around about cast shadows needing to be on to bake emissive lighting, and how everyone just gets around it by using a point light.

This bright, emissive material should be at least putting a little tiny glow behind these statues, but alas, it is not.

Hi!

Is your emissive material strong enough?
The walls behind the emissive meshes, are they static? Do they have enough lightmap resolution to visualize the detailed lighting coming from the emissive area?
Emissive material is connected with the skylight bounce: is it set to higher than the default 1?
Have you built your lights?

I believe you need to check the box “use emissive for static lighting” on the mesh and bake again.

Also, see this page:

  1. Multiplied the material by 5 on the emission, per some guides. Yes.
  2. They are static, yes. These are the default objects with the “Starter Content” with a default wall and nothing else changed. Are you familiar with if they have enough lightmap res to visualize the detailed lighting coming from the emissive area?
  3. “Skylight bounce” this is new to me. Where is this setting?
  4. But of course!

Correct, many of the guides made sure to tell me that. In the screenshot, to the right, you can see that this was checked, and I baked them after the fact.

Do you even have precomputed lighting enabled? Your scene doesn’t look like it has any baked lighting at all, emissive or otherwise…

  1. I’m not sure that’s enough! …have you tried with something like 50?
  2. I always delete those, so I don’t know BUT for sure they are low res by default!! If they are static meshes try to go higher, if brushes then lower! But again it depends on the size of the wall…
  3. World Settings/Lightmass /this is where you control your lighting settings!!!

The issue ended up being a few things.

  1. @Makigirl was right when they said the intensity wasn’t high enough… however.
  2. The main reason why it wasn’t doing it at the lower intensity was because of the shape of the mesh. I rotated and the lighting was cast on the wall to bake, but when I rotated it back to the convex side of the mesh, the lighting wasn’t being cast.

In my experiments, I found the emissive glow to be too low or not configurable, so I just added a point light to fake it and this works better in terms of artistic control.