Download

Emissive Color Overriding decals

My material for the walls and floor have white as the emissive color. When I detach the color the decal is visible. How can I get the decal to show up over the emissive color because I need both to work together. Please help!

Bump? Please?

still need help…

I know I posted on the answerhub for this, but I think this image will help clarify the problem.

And here is the material set up on the emissive:

I have given up trying to get it to work :frowning:

What type of decal are you using? Try switching to Dbuffer decal type (in material settings), that may solve your issue

Try adding a negative emissive color to your decal, masked by your decal’s alpha. If your wall is white (20,20,20) then make your decal have an emissive color value of (-20,-20,-20) for the texels you want “blocked”.

negative values dont work - have there been a solution yet?

Bump, having this same issue!

Bumping this. Is there a solution to this issue?

Having the same issue. Bump

I was having this same issue in 2019 (version 4.21) and even though it is years later I figured I would post what eventually solved it, since I was scouring these same forums. I set Decal Blend Mode to AlphaComoposite and that seemed to have the intended effect (covering the emissive color). Hopefully this works for others / will be helpful for someone.

Thank you so much! It works!