Emissive color is washed out

I’m experimenting with cel-shading, and to get manual control over the color I’m adjusting the emissive color. However, the resulting color is washed out, and it’s very noticeable on certain colors. This occurs on both “Unlit” and “Default Lit” shading model settings.

The expected color can be see when the viewport is “Unlit”, but it is washed out in “Lit”. The effect can be seen in the material editor viewport (I also tried setting the 4vector alpha to 1.0, it didn’t have any effect):

Is there a way to fix this, or an alternative way to control the final color for cel-shading?

It looks like this is an issue with the tonemapper. All the solutions I’ve found are hacky and imperfect.

Possible fix: Dissable Color Grading and Tone mapper completly or...!? - Rendering - Unreal Engine Forums!

More detailed thread about it:

Possibly related:

I’m noticing a similar issue. I’ve just upgraded to 4.16, wasn’t seeing this issue in 4.14, could be a 4.15 thing that I missed in between versions.

Any idea what’s going on here? I read the links above but I’m not doing any kind of tonemapping that I know of.

The tonemapping is on by default. That third link is about the changes made to the default tonemapper in 4.15, so that could be your issue. The comments there talk about the issue and how to adjust it or get better results with it. I’ve disabled it completely in mine for now so I haven’t experimented with any of the modifications.