Download

Editors refuse to open

Hello,

I’ve recently decided to deep dive into Unreal, and start developing a small-scale FPS. I’ve been working on adding all the main features, but today, things just screeched to a halt when the editors stopped opening.

So, whenever I try and open anything (Blueprint, Niagara System, Cascade System, Model, etc.), the editor refuses to open. I can see that there is a second window when I hover over the taskbar, though it only shows the top of the window, the rest is just white. The rest of Unreal works just fine though, and I can start and play my game, just not actually work on it.

I’m running 4.26.2, and the issue persists through restarts of both Unreal and my PC as a whole.

I’m running the latest Windows, and the issue just started happening without me really changing anything on the PC side. I’m not ruling out me breaking something, but I can’t think of exactly what would have caused it.

Has anyone dealt with this issue? I’ve tried everything I can think of aside from a reinstallation, which I’d rather not do.

Thanks : )

There are a few things that can cause this.

First, sometimes, editor windows get minified, and when you open them, they’re just a small few pixels somewhere on the screen, really hard to find. Using the taskbar to hide the main window, and then maximizing the editor window, will bring them back.

Second, if you have an nvidia graphics card, it may be that you’re suffering from a in the drivers (something to do with overlay planes?) This happened to me for a long while and caused windows and menus to only render partially or not at all. There is a fix with a registry edit that is documented here:
https://nvidia.custhelp.com/app/answers/detail/a_id/5157

The miniscule window thing ended up being the cause. The only other example I could find of this issue mentioned Windows key plus up arrow to maximize the window, and that has fixed it. Unfortunately, it was marked as a wrong answer on the other post, so I didn’t think to try it until after I made the post.

Thanks for replying though, I really appreciate it.

1 Like