Editor suddenly really bright / tinted white / bad gamma

Restarting the editor or even the computer doesn’t fix this. Even standalone-launched preview game is affected. How do I fix this?

You’ve ‘obfuscated’ so much, I can’t see anything, but main suspects are:

  1. Using unlit mode

  2. Switched from static to stationary or movable skylight


The pixelated parts are irrelevant, the editor itself is bright, and I assume the viewport is just inheriting that. Project seletion window is working as intended, but as soon as I launch a project, it looks like this.

Hmm, that sounds like more of an operating system / video card issue…

I have managed to narrow it down! For some reason, if I set a project’s buffer type to float instead of 8bit, it becomes bright. Is that a known bug or am I experiencing some oddities?

1 Like

Hmmm, not sure about that…

I am experiencing this but the gamma is VERY low - seemingly happened at random. Any luck troubleshooting this gamma issue further?

For me, changing bit, depth or pass format (don’t remember what exactly) in render settings of the project did it. If I recall correctly, ”float” in one of the settings caused it.

typing ‘gamma 2.2’ in the editor console fixed this for me, no idea why it changed suddenly but this seems to have fixed issue for me

1 Like

@stuck compiling
I can confirm this to! Changing the buffer type to 8-bit fixes the editor GUI / Layout menu and everything being over exposed.

1 Like