Editor stuck at 45 percent

Hello, I purchased a marketplace asset for UE 4.17 (first time loading) and it is stuck at 45%. I did see other posts explaining the shaders are compiling (which is do see a shader compiler process under task manager) but it’s estimated time for shader compiling is 30 minutes, but for me it’s been about 9-10 hours and still no progress. I have a pretty bad HP Pavilion G6 laptop with AMD 6 processor, so I’m thinking this may be the cause. If anyone knows why this is happening, any help is appreciated.

it possible that its your computer. if you open the task manager then try opening your project what are the values of things like cpu, memory, and disk? can you open a new blank project, one with no assets?

I can open a blank blueprint with no assets, and my CPU is at about 64-80, my Memory is at 86 sometimes 87, and my disk is at about 60-99. (I also had it running all night so it’s been about 24 hours with no progress).

Any tips on what I can do?

hgmmm in not sure there is a solution given your hardware. what kind of asset did you buy?
since you can open the editor without issue but its only not working with the asset you bought that shows your pc is having issue with something specific to that asset. you could try opening a blank project then while thats open adding the asset to that project but i fear that you wouldnt be able to reopen that project later even if it worked.
how much ram do you have in your pc? it seems like it was all in use when you were trying to open the project. when your pc starts runnning out of ram it stores what would normally be in ram on the harddrive but given that your hard drive is busy with the retrieval of the project files it wouldnt be able to store and write the files. If i had to guess you are running out of memory and your harddrive can pickup enough slack to keep you afloat. you may need an upgrade