Editor slows down after build?

Hi all.

I’ve got this very, very weird problem which I think is a bug. I just downloaded Engine successfully, downloaded ninja example project, and built it for Android. Rather than Android, project was built for Windows (which is a weird problem itself) and then editor froze, so I had to kill process, but (even worse) problem is that now, whenever I run editor, it freezes for 5-10 second periods, responds for something like 4 seconds, then stops responding for another 5-10 seconds, and so on. I’m on a rather high-spec machine (MSI GE60, Intel Core I7 4700, Nvidia GT750M, 8 GB ram, etc.) so I don’t think problem’s hardware-related, let alone fact that engine was running smoothly up until now. Any ideas?

UPDATE: This even happens on New Project screen. I tried deleting all my projects, still same.

Hi Arshia,

Does verifying your installation produce any errors to ensure nothing became corrupted. Also can you attach your dxdiag?



link text

Here’s DxDiag result. I’m currently getting “subscribe” button again, so I can’t verify my installation just yet, I’ll post back as soon as I do.

Roger, thanks for upload.

As for subscribe issue, take a look here:

Been there actually. update gets stuck at 80 percent (someone else reported same thing I think) but that’s a known bug and it’s being patched, so I’ll just be patient :smiley:
I’m thinking, would it help if I compiled source and did some tracing? (provided I can reproduce this, of course!)

So… Any ideas what might be causing this? I’m really eager to start exploring engine, so I’m hoping this can be fixed…

Hey Arshia,

We’re still looking into partial download issue. 80% download bug was reported here:

You can follow that post for updates if that’s issue you’re currently experiencing. Feel free to leave comments there if you think you can provide more information. Sorry for multiple issues you’re experiencing, but hopefully we’ll get you in editor soon!

OK, so I just used QFE, and launcher’s working fine. I used it to verify my installation, and nothing came up, which I guess means installation is in perfect health. However, SOMETHING is causing engine to hang every 10 seconds or so. If you could give me path to where engine keeps its persistent data, I could try removing some files and seeing how it goes…

I’ve got it!! When I just commented about persistent data, I started thinking about what I’d done prior to this problem, and of course, it was trying to build for Android. At first I thought it was fault of my NDKROOT environment variable (EV for short), since I’d set it to “DONT_HAVE_ONE_YET!” just as a reminder to what EV’s name should be. I removed that one and had no success, but then I went on to remove other EVs and finally when I removed ANDROID_HOME, editor started working beautifully again. I don’t know whether this is a bug of some sort, or it’s my Android SDK’s fault (I’ve been using same SDK installation to compile Unity games BTW), but if I run editor with ANDROID_HOME set to my SDK’s installation folder, I get 10 second freezes in editor. Could you take a look into this and tell me if there’s any info I can provide to help locate problem?