Editor freezes when right-clicking 8K texture

I’ve been trying to use the Open World Demo Collection’s assets, but I am having problems with crashes/freezes of the editor whenever I’m trying to use any of the 8K textures. I decided to resize them to 2K, since it seems that would make it faster to load. My problem is that the editor freezes on some of the textures. Specifically my PC can’t access “T_AlpinePatch001_D_R”. It just freezes the editor every time I double-click it or right-click it. I have managed to export some of the other 8K textures, but the editor freezes every second time I try to do this (or every time). When I look at the memory usage it hovers around 4,5 Gigs used by the Unreal Engine process.

I tried loading the Showcase and Overview maps, without any luck. I got to around 60% and then the editor just crashed, where it opened a windows called “error”, that I couldn’t see. The normal crash report did not show.

PC Specs:
i7-2700K
16GB DDR3 RAM.
Geforce 970 GTX

Hello Pequeno,

From my understanding this Open World Demo project comes with a warning saying that this was built on very high end machines are are not meant for development or modification.

I also understand that this ran on two titans in order to load and run properly.

This is a known issue and these textures take a very long time to load. What is happening is while loading your machine is timing out.

Thanks,

Logan

This makes no sense to me. Why would some of the 8K textures work, while others freeze the editor instantly, even when I just right-click it?
I have had the KiteDemo started and running on this PC, so it’s only the Open World Demo Collection, which is crashing the PC. Also, this is supposed to be memory heavy. I mean, 8K textures shouldn’t crash the editor like this.

Hello Pequeno,

The major difference between the KiteDemo and the Open World Demo is that the KiteDemo is a pre rendered cinematic while the Open World Demo is strictly assets.

Nothing has been optimized, I know of rocks that are in the millions of polygons.

One major issue is all of the 8k textures. They have to be loaded into memory and then they are all compressed. Even with 4k textures this process takes a while.

Currently there is a user who is recreating all of the assets inside of the Open World Demo with 4k textures to make this more friendly for developers.

Logan

I had the KiteDemo running through the Editor, live, not pre-rendered, flying around as the “kite”.
Also - I’m not talking about running all the textures at once in a map, I’m talking about right-clicking one specific 8k texture, which freezes the editor - And the memory usage hovering at 4.5GB. While other 8K textures are working fine. Your explaination does not cover these issues, as far as I am concerned.

Hello Pequeno,

I am sorry that this is still an issue for you.

In your original post you mentioned that you re sized the textures in the Open World Demo to 2k. In your later post you are referencing these textures as still 8K in size.

Are all of the textures converted or just some? Are you attempting to right click on an 8k texture to export it for formatting into a 2k texture?

If so have you re imported those 2k textures that don’t crash the project or are they still outside of your project?

This project was meant to run on very high end machines. What I believe you are experiencing is where your machine is running into it’s memory limit. What happens then is your memory is trying to unload all of those textures that are already loaded and load the texture that are right clicking on and at a certain point there is not enough memory to handle this action.

If you would like you can link me your DxDiag. Just from the information that you linked, I can tell you that they are below the recommended specs for editing and developing with the Open World Demo.

This is a known issue and those even with higher end machines are having issue with the exporting that you have mentioned.

This is a link to a user who was experiencing a similar issue and at the bottom under answers there is an official response for the process on how to accomplish this.

Also note if you scroll to the very bottom that a user with a Titan Card and specs is having a slow time about this process.

Link to Answer : Editor freeze when i drag a mesh - Rendering - Unreal Engine Forums

Please let me know the answer to if what you are trying to do is right clicking for the purpose of exporting for editing, as well as if there are any differences between what you are doing and the answer given on the above posted Answer Hub post.

Thank you,

Logan

I am trying to right-click for the purpose of exporting to lower the textures to 2K.
I can restart the editor, and as the first thing I do is right-click the texture, then the editor freezes. DxDiag included link text.
To me it’s a bug, if one can’t have textures in the content manager, which should one at a time, be able to be loaded into memory.
Furthermore it’s weird that I could work with some of the 8K textures, and not with others. From this I have converted a few (5 or 6 different 8K textures to 2K).

Also - Shouldn’t it be considered a bug, that the editor is not able to unload the textures, and load another, but just freezes up?

Hello Pequeno,

It wouldn’t necessarily be considered a bug.

Mainly because there are limitations to hardware. That is the true purpose of optimization.
If you put every asset you had into a game at the highest possible setting it would crash. Or you would experience a sever performance loss and wouldn’t be playable to anyone.

This particular project has never been through that process.

For that reason Epic has decided to issue a warning whenever you download the open world project explaining that we do not guarantee it will run on your system or is stable.

You do have a fairly good computer. However, for most developers whenever they are going into the post development fazes, render farms and extremely high end computers are utilize to package everything so that when that reaches a player then it is optimized for viewing and game play and not for development.

Logan

I get that. But is my case really not considered a bug?
I only have a single tree in the scene. I open the editor with that scene. Right-click the texture in the content-manager, and the editor then instantly freezes. Especially when I was able to do it with other 8K textures?
I think there is an underlying problem with the whole process of having large textures in there.
Would 32GB of ram help on this, or is it based on the GPU?

Hey Pequeno,

When you load a project on your computer the occupying textures in the contents of the project (texture samples in this case), will take up memory based on the amount of physical memory on your computer.

Physical Memory and GPU both play a part in the ability to load these assets correctly, as their are materials and shaders to compile as well. This is why we warn users about the stability when modifying the assets in this project.

If you could provide us with your ‘dxdiag’, we will investigate further to see if this specific texture is having issues.

Cheers,

Andrew Hurley

I linked my DxDiag in an earlier response, but will link it here again: link text

Hey Pequeno,

After going to a FirstPersonExampleMap I then added to the project the Open World Demo Assets,

I then Located the T_Alpine_001_D_R and tried to right click on it.

I did indeed see that UE4 slowed down and appeared to freeze. However, I waited to see if the editor would crash. After a minute or two UE4 did complete it’s process.

It may take a while to do, however, without an actual crash and I was able to complete the process, this cannot be considered a bug.

I cannot say how long your machine will take to complete the selection of this texture.

Thank you for bringing this to our attention. This is an issue that we are aware of.

Logan

Still experiencing this issue when importing any of the trees from the kite demo. i7 6700k, 16gb of ram, Titan X (pascal)