Editor Freeze When Game Launched

I’m attempting to launch my game on my Android phone, however when I click the button, the editor freezes entirely.
This occurs whether I tell it to launch on my phone or my computer.

[EDIT] I’ve found that if I disable forward rendering in project settings, then it launches fine.

[EDIT 2] *It worked once with deferred rendering, now it does not, again.

Hi Oscar,

Currently I don’t have enough information to determine your issue. Could you provide these things?

  • determine if this occurs in a blank project
  • if so provide a list of steps that causes the error to occur

If you are unable to reproduce this in a blank project you may have to narrow down what is causing the freeze in your project. Unfortunately, I don’t know the contents of your project so it would be impossible for me to ■■■■■ the cause.



It doesn’t occur in a new project, however it does occur in entirely unrelated projects that are much older that I just updated to 4.14
It’s worth noting that the project that I first experienced this in was created in 4.14 though.

Also, due to the ‘Full Rebuild’ setting being disabled, subsequent launches freeze for a much shorter duration.

NOTE: If I let if be while frozen for a while, it eventually becomes responsive again and begins compiling the game - while frozen, Task Manager reports the shader compilers as using a lot of CPU cycles (though it still needs to compile shaders after unfreezing), perhaps it freezes whilst initialising the shader or package compiler?

We are actually experiencing a lot of crashes related to the compiling of shaders in 4.14 and 14.1, this may be tied to memory but that isn’t confirmed as of now. (I think your editor is just getting stuck for an extended period of time, which I can’t really write a JIRA for.)

Would you be willing to provide a small sample project that reproduces this freeze. There is a chance that it may be related to this ticket: Unreal Engine Issues and Bug Tracker (UE-38818) but hard to say without your project or an example project.

I managed to create a basic scene that reproduces the issue:

I created a new blank BP project (in 4.14) with the defaults of ‘scalable’ quality, ‘mobile’ as the target performance, no starter content.

I dragged in a couple of the engine-default cubes accessible from the Modes-Place-Basic menu.

I then created a basic master material with a couple of inputs and then created four instances and changed a few of those settings.

I applied each to one of the cubes, however this did not cause the freeze.

I then copied in one of the (still fairly basic, but still more complex) materials from my own game project, and applied one of the instances to one of the cubes.

I also changed the Android settings only by clicking the ‘configure for android’ button, and then changing the orientation mode to ‘sensor portrait’ (just to change some settings a little bit)

I then enabled forward rendering in the Project-Rendering settings, saved and restarted the editor, attempted to launch on my OnePlus 3 (Android N phone with Snapdragon 820), and witnessed the freeze.
The freeze also occurs when launching on Windows, however.

I then immediately force closed the program so that when I sent it to you, it would not have already compiled the shaders.

NOTE: I did not attempt launching the game on my phone again between the ‘***’ and the final time that experienced the issue.

I hope this allows you to find the issue, though of course, without the constant checking in between changes I made, I cannot pinpoint the cause of the issue - hence why I included my EXACT sequence of alterations.

link text

NOTE: Apparently the tri-asterix became a separator.

Hey Oscar Cooke-Abbott,

I attempted to launch your project on Windows and an Android device, and did get a slight freeze initially. After a few moments however, the freezing dissipated and the launch on process continued as normal.

Can you provide me with your ‘dxdiag’ so I can take a look at your system specifications?

How long are you waiting for the freeze before you force quit the program?

Thank you,

Why would the time I waited before quitting it matter as it works eventually?

link text

Sorry but this issue was never actually resolved, and in testing 4.15.0 now, the issue is still present?

We were not able to reproduce the issue internally, so unless we can get a way to get it occur on our end it is going to be an invalid bug report and get immediately kicked back.


But you said you did experience a freeze, and then asked for my DXDiag, after which though you didn’t reply?
I am still experiencing this on every project I have - even ones I created from scratch in 4.15

I’ve just done a clean reinstallation of Windows, and the issue persists - however after reading the output log, and looking at the file size after installation, it seems to me that UE is compiling ALL the Android support files and resources into the app - despite the fact that I’m not using any, and my project itself has only a few low-poly meshes and like 5 1024^2 greyscale textures.

So I have not been able to reproduce your issue on my end, and your issue seems to have been narrowed down the the compiling of all the android support files. I would need a way to reproduce any of what you are reporting in order to enter it as a bug report.

What are the packaging settings you are using as well as the Android specific settings?


So looking at your settings and compiling all of the information here, I believe the freeze could be related to the type of phone you are using in conjunction with the Vulkan renderer you have enabled.

As you can see in the Android Vulkan Mobile Renderer documentation, you need to be using a source build downloaded from GitHub and follow the instructions laid out explicitly.

I can already tell you are missing some important steps like setting the minimal SDK and Target SDK versions to 19 as the document points out. You also need to make sure Mobile HDR is checked and the ‘Support OpenGL ES2’ which I noticed has been left unchecked in your image.

Once you have set Vulkan up correctly, or if you disable the option and still get the freeze etc. Let me know and we can continue to troubleshoot.


The issue has always occurred regardless of whether or not Vulkan was enabled (I didn’t know it required source or anything - I just thought I’d try it since my 820 supports it).
The issue still persists after disabling Vulkan and reenabliing ES2 (I disabled it because I kept getting material warnings about a noise node, but I changed it to simplex and it fixed it anyway).
Loads of unused engine assets still get compiled after a super long engine freeze - again during which shader compilers (as well as the engine) are using all the CPU.

Why did you accept the answer?!

We have not been able to reproduce the issue on our end, and no more information was provided. With that said, AnswerHub has issues with auto-accepting answers sometimes when the post is opened and an answer exists. Simply refreshing the page will sometimes auto-accept an answer.

Unless we can reproduce the issue on our end then we cannot enter a bug for the issue. It is normal that when trying to package and compiling shaders simultaneously there are slight freezes in the engine. This could be exaggerated depending on your pc’s hardware and other variables consuming memory during this process.