Editor Camera Visible as Sphere In-Game

I haven’t found a consistent cause, but sometimes the editor camera will begin to appear in-game, with no way to stop it. I haven’t seen this behavior prior to 4.15 and it seems to happen after migrating maps from one 4.15 project to another. The outliner shows the camera being spawned after begin play.

This is an example editor view:

Here is the in-game view of that viewpoint. Note the sphere:

Here is a wireframe showing the object to be a default unreal sphere:

The work-around I’m using is to leave the editor camera in a place that can’t be seen, but this seems like a bug with the material the editor camera is using or the visible in-game flag getting reset. Is there a better work around or known root cause?

Hello Edenxiii,

Unfortunately, I was not able to reproduce your issue on our end. I have a couple of questions that will help me narrow down your issue?

  1. Does the editor camera show up consistently during play?
  2. If so under what conditions can you get it to show in play?
  3. Would you be willing to share your project with me so I can investigate your issue further?

If you are uncomfortable posting any public link you can privately message me on the forums via my profile which is linked here:

https://forums.unrealengine.com/member.php?680446-ThomasVanZeeland

Thank you!

As I was reducing the project down to post for troubleshooting, I noticed that not only was a CameraObject being spawned automatically, but so was a DefaultPawn.

I added a GetAllActors in a test scene to find all the CameraObjects, and called destroy on all but the camera attached to my character pawn. The sphere was still there. When I repeated this for all DefaultPawn objects, the sphere was gone. Clicking the created DefaultPawn object in the world outliner while running the game in PIE shows its origin as exactly where the sphere I observed would be centered.

It turns out the game mode was set to the default ‘GameMode’ rather than the custom one I created, so this isn’t so much a bug as confusion on my part.

As a quality of life suggestion: when a project specifies a game mode that can not be found (as in my case where the config files copied over to the new project specified a custom game mode, but the game mode definition was not considered a dependency of the maps I migrated and thus were not in the content directory) it should report the error in the editor window.

Thank you for responding, Thomas

Such big thanks man! Im woking on 4.23 and still issue. Was really annoying. By the way… did you know what caused it?

Thanks a lot man.

Nice day

Same happened to me since i’m manually spawning my own pawn as well. Found this thread which tipped me off to the Default Pawn. Only thing missing here is to mention that setting the “default pawn class” to None rather than “Default Pawn” if you’re going to be manually spawning your own pawns/characters.

Thanks.
Changing Default Pawn Class to ‘none’ inside my custom game mode got rid of it!