Download

Early Access for ARKit for iOS available now on GitHub

Apple has announced support for AR for iOS. It’s high-end, powered by Unreal, and early access support for ARKit is available now on GitHub!

At WWDC, Apple surprised the whole industry by revealing a visionary and wide-reaching set of AR and VR technologies, demonstrated live with film-quality content created by industry luminaries using Unreal Engine 4. And the best news: Unreal Engine 4’s early access support for ARKit is available now on GitHub (login required)! So, you can get started building AR experiences right now with 100% complete source code that’s ready to compile and run. Binary support is coming with the Unreal Engine 4.17 Preview in July followed by launch in early August.

The future of AR just got real - and Unreal!

Getting a 404 even when Im logged in?

Howdy, did you associate your GitHub account with your Epic ID? If so, let me know and I’ll try and trace it down on this end.

Thanks.

Got it worked out. My account was somehow un-linked I guess. Hadn’t tried it in a couple years.

I have a problem after following your installation guide :

ERROR: UBT ERROR: Failed to produce item: /Applications/UE4.17/Engine/Binaries/Mac/UE4Editor.app/Contents/MacOS/UE4Editor-MetalRHI.dylib

What i did :

Download the Zip from the github
Open the stup and generate file
Build the ShaderCompileWorker and UnrealLightmass with the new Xcode Beta
Then Build the UE4 and get this error.
I tried to compile the SampleProject but same problem.

Thank you

My build ends with the exact same error… I’ve also seen in another thread that some people are having problems using Nvidia cards but that’s a step forward we are.

In fact in the last step you mention I tried to build and run the ARSample scheme (making sure before that building configuration was set to Development Editor).

There’s also this error:

I’m using a MacPro2010 10.12.5 (16F73) with Xcode Version 9.0 beta 2 (9M137d) with a Nvidia Quadro K5000 for Mac 378.05.05.15f01 (up to date)

Any idea of how to troubleshoot this error during the ARSample build?

solution here: ARKit: UE4-MetalRHI.dylib is missing, can't compile editor in Xcode Beta - UE4 AnswerHub

I have got the sample building but after running from Xcode it seems to take forever to run!

Im currently on the splash screen at Initializing… 45% (after quite a few minutes)

anyone have any clues as to how this can run faster!?

@EkstraReality

Make sure you

git checkout remotes/origin/dev-ar-kit

before you run any of the setup scripts

then add the nullable keyword!

Hi,
Has anybody had any luck getting ARKit to work in 4.17 Preview 3?
I am able to load ARSample and work with the ARKit components, but the editor crashes when I try to launch on device. I also tried creating a project from scratch and adding to it an ARKitCamera - in that case, the editor didn’t crash on launch but the app crashed on startup.
Any ideas?

No luck, I get this error any time I add the ARKit plugin and try to launch on device:

UnrealBuildTool: ERROR: Failed to start local process for action (“Cannot start process because a file name has not been provided.”): -o BatchMode=yes ${CURRENT_USER}@ “cd “/” && xcode-select --print-path”

It launches fine without the plugin (preview 3)

Kinda Sheado. I was able to open a copy of the ARKit sample project with 4.17p3 (it converted in place). After waiting for the shaders to compile, I was able to package it out to an IPA. Starting that up on the device though did what happened to you – black screen for a half second then crash.

FWIW - the IPA from the dev-arkit branch of the same project was ~206MB, while this from 4.17p3 was ~135MB (granted, that one failed). This is with XCode 9 Beta 2.

thanks for info @jawatr & @Burly.
Seems very similar to the types of issues I’m seeing. It seems like a few people (according to other threads) have their projects up and running on their devices… Not sure what the difference is - maybe the Mac they’re deploying from? I’m using an iMac with an NVidia video card.

I am able to get the ARKit sample project running on device – but through exactly one specific path: Building and running the ARkit Sample project from the latest dev-arkit branch, using XCode 9 Beta 2 (only), and packaging to IPA to side load through iTunes. No other combination pans out for me.

Even so, that only kinda works. Running the sample on my iPhone, the orientation is all rotated and skewed. I can see the world orientation plane, but the camera is rotated 90 degrees CCW and the aspect ratio is messed up. The geometry does project into the view, but the world tracking is not really working so it’s a mess. This is on an iPhone 7 Plus, with IOS11 beta 3 as well as beta 4, built from a Mid 2012 MBP with an NVidia GT 650M.
@Sheado I hadn’t though to try to force open the sample in the latest 4.17p3 until you mentioned it. When that came out, the first thing I did was look for an AR option in the new project browser. When that wasn’t there, I figured it didn’t have some level of support ready yet. I wish I knew more about how all these pieces go together to know why it’s not.

Have you been been able to get it working from the dev-arkit branch?

Now that I’ve finally gotten something to work, I was going to try to poke more around the project to see if I can get it to orient properly.

Ya, maybe the reason is I’m compiling from Windows. The thing is that it works fine without ARKit… :confused:

@Burly - Interesting. Sounds like we have similar Macs (and I’m testing on an iPhone 7). I tried XCode 9 Beta 2 at one point (and deleted it already), but the editor always crashed no matter what I tried with the dev-ar-kit branch.

To try out the sample in 4.17p3 I did the following:

  • copy the ARSample directory from dev-ar-kit to a new location
  • open the project with 4.17p3
  • go to plugins in the menu: Plugins | Unreal Engine Documentation
  • search for ARKit and enable it
  • your project should now have access to all the ARKit components
    Or at least those were roughly the steps.

I’m about halfway through dev on my AR project, but I have yet to test it on an actual device =/ Hopefully a fix is coming soon =]

I have the exact same issue with the ARKit Sample project, I cannot get it to launch on a device, and when I package the app and install directly, it crashes a few seconds after opening it. Has anyone got the ARKit Sample project to work on an iOS Device from 4.17 preview 3? I could not get the ArKit Branch on github to compile.

I found this in my log using the same procedure to get it running from p3.

The fix is to add a key to the plist

<key>NSCameraUsageDescription</key>
<string>$(PRODUCT_NAME) camera use.</string>

In UE4 ->Project settings -> iOS there is an extra PList data field, where you can add the text above.

Found the solution here

Now it loads and runs but I get a black screen (camera not working), on to the next fix :slight_smile:

Fixed the black screen by setting the default game mode <doh!>

Just trying to figure out how to keep the tracking updating now…

hi,the app can run now, but i still got a black screen even i set the game mode. how you did that?
Thank you so much.