Dynamic Shadows not showing with Translucent Material

Hello everybody, we are completely lost.

we have a scene with a stationary sun, with both static and cascade shadows. Dynamic shadows start to appear when you are a distance of 350. In the scene we have a couple of big doors with windows on them. Opaque material is a normal white material and the translucent is the M_Glass provided in the default UE file.

The problem is the dynamic part of the light is not casting translucent shadows in game or in the viewport (cascade shadows not working with translucency). But when you select the Static Mesh in the viewport, the shadows appear. The static part of the light is working though, the static shadows are correct.

We have also tried with different meshes, and the problem persists. So we deduce is an issue with the light source, or the translucent material, but we can’t figure it out.

We attach some images of the scene. The double door is an actor blueprint, it’s set as movable and one of the windows has the option ‘Light as if static’ checked. The single window is a simple Static Mesh and is set as static.

Here you can see the mesh appears completely opaque, the translucent glass is not working at all. No matter if the Mesh is movable or static. Same with the translucent cube.

The static shadow is working correctly. You can see in the double door, that we window with the option ‘Light as if static’ is casting a static shadow.

You can see here the transition from cascade shadow to static shadow clearly happening.

When you click on the meshes in the Viewport, the dynamic shadows appear! It also happens when we have Show > Collision enabled.


Any ideas on what’s happening? We hope you could help us. Thanks in advance!

I have the same problem with Raytrace soft shadows, so I’m also looking for help with this one :slight_smile:

You should be able to disable shadows on a per-section basis in the static mesh viewer (by double clicking the static mesh in the content browser). Not sure if its possible to avoid that issue with distance field shadows.