Dynamic parameter has no effect on Beam Particles

Dynamic parameter setup in material does not work with Beam particles. Test material I setup worked fine with regular particles. Could you check if this is a bug?

Can you post your effect to a location one of our QA people can access, I am sending off an email to help verify the issue. I have not had any problems with DynamicParameters and Beams, but I also have not used them in conjunction in a month or two so there might be an issue.


Hi Pinepanda,

Thank you for the feed back. We were able to reproduce your issue here, so the developers will be looking into this.

Thanks, TJ

This is still an issue.

Hi Everyone -

I want to apologize, this issue fill through the cracks when we were changing over to a new reporting system. I have reported it again, for reference UE-13679 and as soon as I hear something I will report back here to you.

Thank You Clapfoot Matt for bringing this to our attention.


You can use particle color in place of dynamic parameters to modify material parameters as a work around. If you want to scale your color you can setup color as an InstanceParam and say modify it with your R channel, then use another channel such as G or B to modify a separate material parameter.

Sorry for the issue, I would suggest using the above method as I don’t see this getting changed in the very near future as we are focusing efforts on Niagara and issues which are critical path for Cascade (i.e. a bug which is causing crashes etc.)

Hi , is there any update to this bug?

Hi Devero -

Unfortunately this bug is currently backlogged. As I know more I will report back here.

Thank You


I used the RBGA channels with particle color in Fortified to create similar effects with dynamic parameters as noted in this thread somewhere. It works the same way. There are quirks but you can still create cool effects.

too bad Niagara took another three years eh… Still an issue in 4.19

4.26 still an issue. still not fixed