Dynamic light with no shadows bleed through walls

Hi, i’m using dynamic lighting in my game. My problem is that when i place pointlight in scene and turn off casting shadows light is bleeding through walls. Is that possible to some how prevent that bleeding? Or i need to have casting shadows turned on?

Here are some screenshots:
Cast Off

Cast On:

It looks like part of the point light radius in inside the room.

Yeah, without that is hard for me to place this light, the room in other side is really small. Okay, i will try figure out how to place that light. Thanks

You need to have CastShadow enabled for it to not bleed through the wall. Casting a shadow is just blocking light… so if you aren’t blocking light, it will go through the wall.