Dynamic Foliage Shadow Issue

I have this issue.
(something to note about the main tree in the video, there is a second trunk mesh being used as a detail mesh for roots, that’s why it looks like part of the trunk is still casting a shadow)

Here is a second video of the issue.

It only happens on Shipping Builds. In Editor and Dev Builds are fine.
Happens on 4.24 and 4.25

I have figured out it’s only on 3 of my Foliage Type Assets that have been painted down using foliage painter that have this bug.
I just can’t figure out why it’s happening or how to fix it.
The Shadows are Dynamic.

Things I have tried.

  • Swapping out the mesh in the Foliage Type
  • Creating a new Foliage Type and using the “Replace With” function.
  • Creating a new Foliage Type and manually replacing the old trees with the new one.
  • Getting old versions of the Map and other files to see if it was something we introduced.
  • Pressing the Build button to rebuild texture streaming and reflection captures etc.
  • I also tried increasing the bounds on the tree static mesh details.

Nice look!

not really enough info here to debug it.
it could simply be that the meshes do not have distance fields generated - are you using distance fields?
Or that they have the option for shadow disabled on distance field. or that their tangent needs to be set.

as to why it would work in one version yet not the other. Completely not sure, but. Delete everything in the output pick what to delete from /saved
and reload the editor.
Wait that day or 2 of shader compile time ;P, and try a build.
that sometims happens to fix my “can’t explain it” errors…