DX11 feature level 10.0 is required to run the engine.

I am currently running on a 2-year old, relatively high-end laptop. I had troubles installing UE4 in the first place, after downloading the launcher, running the launcher didn’t appear to run anything. Checking taskmanager, I verified after running the launcher there was no unreal process running. After some research, I found the only way to get the launcher running was to run with a -opengl command line parameter. With that change, I appeared to successfully download the Unreal Engine 4 installation.

However, now that the Engine is installed, when I click “Launch Unreal Engine 4.7.2”, I get the error message:
“DX11 feature level 10.0 is required to run the engine.”
I press OK and it just returns me to the launcher.

I checked my graphics card Quadro K2000M, and it appears to support DX11, but I cannot confirm it’s feature level.

I am up to date on all critical windows updates and have updated my graphics card drivers.

link textAttached is my dxdiag.

Hey Turand,

Since you’re running on a laptop, I’m going to assume that you have a legit copy of Windows. However, I did run across a few issues where people in the community actually had pirated versions of Windows and it was causing this error to populate. So if you are by any chance running a pirated copy of Windows, you may want to consider buying Windows. However, if you are on a legit copy of Windows, ignore the above paragraph.

After doing some research on the issue that you’re experiencing, I’ve came across another AnswerHub which has worked for some in the past. Could you please attempt to follow the steps in the accepted answer of: UE4Editor-Cmd.exe crashed after launch - Programming & Scripting - Unreal Engine Forums

If that does not work, please let me know and I’ll further investigate this for you. :slight_smile:

thanks so much for the quick response. Alas, I must be destined not to study unreal development this week. I accidentally set the launcher to install 4.7.3, paused it, and somehow it deleted my 4.7.2 installation. I am on vacation where the island has 3rd world internet connectivity, I will have no chance to reinstall the engine this week. Once I get back to civilization, I will reinstall the engine and try your suggestion. Thanks!

Turand,

That’s very unfortunate that you’re not able to download the editor while you’re on vacation. Nonetheless, we’ll still be here when you get back from your vacation. Enjoy your time, and reply back here when you’re able to try the suggestions made earlier.

Cheers!

Ok, got a chance to try it. Unfortunately, it did not work. I added performance options for both the editor and editor-cmd with no luck. I am not surprised though, I don’t have an integrated graphics card, just the Quadro K2000M, and you can see I have the feature level required:

[link text][2]

See my comment above.

Hey Turand,

Could you please verify that you did not update your graphics card to a beta graphics card driver? Sometimes beta drivers have unresolved bugs which make it difficult for your graphics card to run properly. Also, if you have an Oculus Rift or any other VR plugged in, please make sure that it’s disconnected.

Hopefully one of these suggestions will resolve the issue you’re experiencing.

Cheers!

Hi Samantha. I do not have any VR plugged in (I wish I had one tho :slight_smile:
I am running an “ODE” version directly from NVidia. Technically, it is a few levels ahead of the certified HP driver for the laptop, I will revert it and let you know.

Hello again Samantha. I have rolled back my driver to the certified version 341.44 for my hp 8570w laptop (from http://h20564.www2.hp.com/hpsc/swd/public/readIndex?sp4ts.oid=5257503&swLangOid=8&swEnvOid=4060)

Alas, still the same problem.

Looking through the source code, the error seems to originate in WindowsDynamicRHI.cpp in the PlatformCreateDynamicRHI method.

		DynamicRHIModule = &FModuleManager::LoadModuleChecked<IDynamicRHIModule>(TEXT("D3D11RHI"));

		if (!DynamicRHIModule->IsSupported())
		{
			FMessageDialog::Open(EAppMsgType::Ok, NSLOCTEXT("WindowsDynamicRHI", "RequiredDX11Feature", "DX11 feature level 10.0 is required to run the engine."));
			FPlatformMisc::RequestExit(1);
			DynamicRHIModule = NULL;
		}

This code is not executed if running the engine in OpenGL mode, so one work around is to run the editor (and engine) in OpenGL. How can I change the command parameters to the Unreal Editor from the Launcher?

Confirmed, if I manually invoke the editor with an -opengl command line option, the editor will launch. Be nice to get this working with DX considering my graphics card should support the feature level, but at least I have a work around.

Hey Turand,

I’m glad you were able to get this working. If you run into this issue again, please update this post so that we can assist you further. In the meantime, I’m making the appropriate parties aware of the situation you experienced.

Thanks! :slight_smile:

That does NOT work with server 2008…WHY would you run a DEDICATED SERVER on windows 7??? WHY??? WHY would you design a GAME DEVELOPMENT PACKAGE that wont RUN ON A SERVER OS???

I have this issue with win10 and UE 4.16.0.
dxdiag shows feature levels: 11_1,11_0,10_1,10_0,9_3,9_2,9_1

when i launch the editor on win10 with - opengl it crashes with a crash dialog.

SOLVED - the VirtualBox virtual graphics card does not support this feature but the Vmware one does.

OK after spending some time i solved mine with below steps since the engine was working fine before for me in the same win7 which i am currently in.
i didn’t update my graphic card btw gtx 1070

1- i installed dx 11 from this link Google Drive: Sign-in
in case the link dead one day try to find the latest dx 11 from other website.

2- I installed below 2 update manually both are for win 7 x64
Windows6.1-KB2670838-x64.msu Download Platform Update for Windows 7 from Official Microsoft Download Center
Windows6.1-KB3033929-x64.msu Download Security Update for Windows 7 for x64-based Systems (KB3033929) from Official Microsoft Download Center
3- restart your pc to take effect

i think the reason of the problem for me was i uninstalled above 2 updates couple of weeks ago which might removed some files with it so i haven’t to reinstall them again which now everything works fine :slight_smile:

Same problem with DX11 prompt. If I try to start with -opengl it just crashes. I’ve also tried -DX12 but the editor runs incredibly slowly. Surprised this is still an issue, and not sure why it’s marked as “answered”.

I’ve had the same issue. I downloaded and installed the Epic Games Launcher, and downloaded the Unreal Engine 4 (4.19.2) in the launcher, but when I try to launch the Unreal Editor, the DX11 error message appears.

I use a Desktop PC running on Windows 10 Pro (64-bit). It comes with DirectX 12 (9.0 — 12.1), with all features activated. The PC was built (assembled) a few weeks ago, so all hardware and drivers are up to date. I’ve tried updating the Windows and the DirectX, but to no effect…

My PC has an MSI B350M Gaming Pro motherboard. The processor is an AMD Ryzen 3 2200G with an MSI Radeon RX Vega graphics card (4 CPUs, ~3.5GHz).

Your article shared a lot of useful information for me. http://hotmailentrarno.com/