the DUMPMOVIE function seem to be completely broken. I have tried it with 2 of my projects and I have tried it with sample project for version 4.7 including the Matineee Fight projects sample and it doesn’t output anything.

This has me completely stopped at work as I cannot render out anything for my client been posting about this for a week and have been unable o get a response.

Hi ,

The functionality of the -DUMPMOVIE command line argument is not broken that I can see. This functionality requires that the project be packaged before this will work.

For instance, I tested this with the Matinee Fight Scene from the Learn tab in the Launcher. Here are my steps:

  • I packaged the project and then located the .exe file that allows the game to load.
  • I created a shortcut of this > right-click > properties > add -DUMPMOVIE after the .exe

  • In the folder where this is located navigate to the []Projects Name] \ Saved \ Screenshots \ WindowsNoEditor \

  • At this point the screen shots for the rendered frames will be located here.

This will not result in a rendered “movie” like an .avi or .mp4 though. This will give you the rendered frames from your matinee animation that is set to play on start. These images will then need to be used in another application to create your movie, add sound, along with any other that were not handled with matinee (ie. fade in/out).

This documentation here is from UDK, but the process is still the same: UDK | CapturingCinematicsAndGameplay Frames

I hope this helps.

Well something needs to be done as most of the post explaining this are wrong. 90% claim that you are supposed to point to the editor.exe and make no mention of packaging.

sent a note to the Documentation team to try and make that clearer in the official doc’s. Hopefully it will be added soon.


Thanks for your help.

Actually, one of the devs was discussing this with me and there should be a way to do it from the editor with standalone mode. I was not aware of this method and am investigating it at the moment. I don’t know when I’ll have an answer back to you, but I’ll try as to as soon as possible.

For now though, the packaging method should get you going until I can test otherwise.

Hey ,

I made a little headway with your project files this morning. There’s actually no need to use a player to get the streaming to work. You may have mentioned it somewhere else, but I’m not sure. With World composition I was able to bring up the levels panel and then select the option for “Summons World Composition” (small button next to the Levels Drop down in the Levels Window.

This will bring up World Composition. There wasn’t anything in here for me initially. I Selected all the maps labeled “Flip Test” and set to “Load.” Since this is a very large world it took about 20 minutes on my computer to load everything. So you may need to give it some time there.

Once this worked I could then go to the matinee and set the output I wanted. In this case I just used JPEG since it was very small file size along with setting to disable texture streaming. I let it go for a bit and it rendered all the frames that I could see. I didn’t do the entire thing since it’s a long matinee sequence.

I even did the same test for a avi video for ~30 seconds. I’ve sent you this as a demonstration.

One other thing I did was make all the lighting and the skylight dynamic. having everything set to stationary and unbuilt was hitching up originally. Building lighting for a world this size is pretty unreasonable and would require much more resources than I even have access to.

Let me know how this works out for you. This looks like it’s working properly on my end without any other crazy setups or need for Matinee Events to be called.

There was no need to adjust anything in the Level BP aside from making sure the Matinee would play through.

So I have found that the issue is not with dumpmovie but rather with the -BENCHMARK function see post here: