Dropping lots of frames in VR with latest Hotfix (4.10.1)

Updated this morning to 4.10.1.
Last night project was working perfectly, 90fps all the time. In new version, we get a lot of dropped frames (75-80fps).
This wasn’t happening when we looked at the ground, was especially bad when we looked upwards at our Sky Sphere or used our spot-light torch.

We’re using the HTC Vive.

We ran a few tests on the Vive with a 4.10 project and at first I was running about 75 FPS but after the following changes I was able to get the Vive back up to 90 FPS.

  1. First I set the Directional light from stationary to static and added a static sky light and then re-built the level lighting.
  2. Next I added a PP Volume, set it to unbounded and then turned off the following features.
  • Bloom was set to .225
  • Auto Exposure Min and Max Brightness was set to 1
  • Lense Flares Intensity was set to 0
  • Set AO Intensity to 0
  • Screen Space Reflections are set to 0 for intensity and quality

If you do all of the above and they are still having issues then it is most likely a content issue. If this is the case you could check the link below for information on performance profiling.

Link: Performance and Profiling | Unreal Engine Documentation

Thanks for the tips Rudy, we ended up just turning off AO and everything worked perfectly after that, but I’ll bookmark this for later in case we get the same problem later on :slight_smile:

I am happy to hear that you have found a solution to your issue. I will convert your last comment into a answer. If this issue returns please feel free to update this thread with additional information.

Make it a great day