Download

"Draw Texture" draws just a color and " Draw Texture Simple " is drawing a texture .

If i put a grass texture it shows green quad and if i put fire texture " made of yellow and red " it shows a red quad .

Like i takes only one pixel of the image…

" Draw Texture Simple " however, shows the texture like it should .

I’v tried to play with the values but it didn’t help, Is there anyway to solve this ?

I’v just tried it in 4.1.1 and still the same results, what am i doing wrong ?

I not sure but you need touch the texture u texture uwidth , etc. Imo this node is useful only if you use textures atlas. I can be wrong…

I’v tried anything and now i’v checked the “Draw Material” and “Draw Material Simple” and i have exactly the same issue .

“Draw Material” shows only one color, depends on the color of the texture, and “Draw Material” works as it should .

This is happening in 4.1 and 4.1.1

Draw Texture is working fine here. From your screenshot, you havent defined TextureUWidth or TextureVHeight, which should be between 0…1 depending on how much of the image you want to show, since its set to 0 its probably using the first pixel only.

Take a look at the screenshot below:

0790a8767b2abb9cb012590628606aa0dd10a9fc.jpeg

Probably “Draw Material” set Utexture, Uwidth, Vtexture, Vwidth to fit the size of the texture in the magic part of the engine.

maybe

texture U 0
texture V 1
Uwidth 1
Vwidth 1

Thanks erWilly, that was the problen, tried high numbers and it didnt work but 1 is working :S

You’ll want to understand UV coordinates better if you’re using the non-simple draw method. They’re just as important as your screen X/Y/W/H.

If you were using an atlas (which you should for the final version), the UV X/Y/W/H would definitely not just be 0/0/1/1 but something more like 0.1/0.2/0.4/0.25

Yeah i know atlas from unity, Thanks for the advice .