Download

Draw Distance Problem

Hi UE Forum!
so i have a little Problem with the Draw Distance (Vegetation).
I painted some Grass, but with my Placeholder Camera i can’t see it. So i think this i a Draw Distance Problem ?
How can i expand the Draw Distance on my Cameras in UE4 ?

fU5fVmg.jpg

JOPF2eg.jpg

Do you have the view distance in the editor scalability settings set all the way up?

Hmm, I don’t actually know how grass works, but there’s also min and max draw distances for the mesh components of actors. In the details panel under rendering I think.

I’ll try to make it as simple as possible. I just learned how to do this so you may need to experiment with it. This can apply to any type of foliage too.

  1. Select the foliage type that you want to alter39135e5224aca0d360345bc4f68164d9eb9fb9f9.jpeg
  2. Now go to the instance settings and make sure the cull distance is set to 0.e5f99a11f7a99edb2cf7dacb35d73af6d94d6fa6.jpeg
  3. Edit the max cull distance to a suitable distance. Once you move it past 0 the selected foliage will disappear until you raise the max cull distance.
    I hope this helped you.

thanks for the answers. But this doesn’t helped for me.
The Problem is, that the Draw Distance of the second Camera (in the lower right Corner) isn’t far or high enough i would gues.
Is there a way to adjust this ?bc8e23813829c31d7898b9188b77e21fa76c4cb1.jpeg

Here are my Settings:

settings.JPG

Hi,
cull distance Min should be 0 I think. Max is when you want it not to be rendered. I’m having similar issues in that these settings don’t do anything.
Ive spent two days messing with materials, engine settings and everything else and still the cull distance wont change. With grass you might want
to use the procedural system designed for it which uses the landscape material not the foliage tool.

Hope that helps.