Downloading Marketplace Assets on Linux

My day work put me in a situation where I needed to download marketplace assets on a Linux machine. Given the fact that Linux does not support the Epic Launcher and that the Epic Launcher is the only way to download assets, this presented a problem.

I came up with a solution for me, maybe others would like it too.

I made a node.js app that runs in your shell/command prompt/powershell that gives you access to downloading marketplace assets you own. You need to have NodeJS installed, and to log in using the app, for it to work. It will download assets to your current working directory in a subfolder called ‘download’. It doesn’t have any advanced features like download resuming, caching, etc. like Epic’s launcher, but if you’re in a pinch, it works. At least it works on Windows / Ubuntu (thats all I’ve tested).

If you have nodejs installed, getting it is as simple as

npm install -g Allar/ue4-mp-downloader


Theres bound to be bugs. For example, currently Code Plugins result in a 403 (Forbidden) error, and it takes up a little bit more memory than it should. Looking for help with either.

Github for the app: GitHub - Allar/ue4-mp-downloader: Shell utility to download owned assets from the UE4 marketplace.</ti


Seriously. You are really the hero. Excellent work.

1 Like

Awesome Allar! But it doesn’t work for me on ubuntu - after login I only get the source response written to console with “web auth failed” (Yes Credentials are correct). Analyzing the response it doesn’t seem to send the required header

'access-control-expose-headers'] == 'X-EPIC-LOGIN-COMPLETE-REDIRECT'

And it would be great to implement the epic provided ■■■■■ from learning tab.
I don’t get it why epic still doesn’t support the linux devs with the launcher :frowning:

And the Repo has been renamed:


npm install -g Allar/ue4-mp-downloader

Aye, looks like Epic’s auth process changed ever so slightly. Problem with writing unofficial third party code, heh.

I’ve updated the repo and instructions in the first post, you should be able to re-install via npm to get the latest version and it /should/ work.

As for Learn assets and other things, I believe the issue is that the manifest files for these work slightly differently and I haven’t had time to isolate and correct for these differences. Maybe some day.

1 Like

Is there anyway after new years could you fix your downloader?

Seems like something changed again. I can log in, and browse my items, but trying to download gives me an error:

Getting item manifest.
Error getting item manifest. Error code: 403
Failed to get item manifest. <?xml version="1.0" encoding="UTF-8"?><Error><Code>MissingKey</Code><Message>Missing Key-Pair-Id query parameter or cookie value</Message></Error>

SleepProgger fixed it in the fix_download branch (GitHub - SleepProgger/ue4-mp-downloader at fix_download), I’m using it right now.

npm install -g

use like Allar version.

I can’t login with my Account. I wonder if I can redirect manually my credentials. I am using Centos 7 haha

Maybe try: GitHub - Erlandys/UE4LinuxLauncher

Hi! Just installed v1.3.0. but can’l login with message: “Failed to log in.” Any clue?

for me login is not working

same here, CentOS 7

login failed

login failing for me also (Manjaro)

Ah yes, I tried this four ways to Sunday. This would be great if it was still working. Any plans on getting this working again?

Just another voice asking to get this working again. I’d even be willing to support the effort monetarily through a patreon or buy me a coffee or directly through paypall.

BEST OPTION for me at least (and only for UE assets download) so far is this one, it even looks the closest to the real launcher and is maybe easier to use for people like me next to a shell alternative. (I remember having some login issues at the beginning but closing and starting it again pushed the login popup to the front I think, or simply reinstall it quickly, the solution was fast as I remember):…he-marketplace

I’m downloading UE4 Assets into the cache by right clicking an asset and choose to download to cache. cache folder is inside the ue4launchers directory and is named “cache”. From there I copy the assets manually to my custom UE4Assets folder. From there I copy the ones I need to my UE projects. Easy enough.

But just now I came across the real launcher working with lutris:

So far it’s working great, but haven’t yet tried to download any assets/games/whatever but the launcher so far seems to work flawlessly… Of course you do not want to install the Engine as you wanna compile that on and for linux directly, but might come in handy for assets and games maybe as well? :slight_smile: I hope because I’ll have to play Kena in August!!! :slight_smile:

Edit: Best option stays best option even after testing the real launcher in wine. The problem with the wine version is that there’s no engine installed and I’m certainly not going to install one. Problem: Assets that are already a “project” can be downloaded by choosing “create project”. This will download the asset and put it into the project folder you specified, working without engine, files are on the disk. Then there’s assets that can be added via “Add to project” button. For those you already need a project. So download first an asset that creates a project, then you can download assets that need a project via “add to project” button. That’s already a bit annoying. But then come assets that have the “Install to engine” button, and for that, you guessed it, an engine needs to be installed. So that’s not gonna work. Maybe but just maybe some games from the game store would run, haven’t tested that yet.

Im 4 years still waits marketplace. Maybe Epic wants for Linux users not buy on Marketplace =)

Im done 3 games on other engine while i waiting.
One is 2d and released on Steam. Named Reskue.
Im dev retro and indie. but still interests UT4 on Linux.
Im previous work with UDK 3.5 (UE3.5) its works perfectly but models have been preloaded for UDK.

1 Like

Actually Lutris IS perfect solution. It has very straightforward way of installing Epic Launcher. There you will see all your subscribed Marketplace assets. The only problem is that most of them will have “add to project” option and you can’t create projects without downloading whole Windows version of UE in wine… However what you just need to do is:

  1. Navigate to your wine filesystem of Epic Launcher (~/Games/Epic/epic-games-store/drive_c/)
  2. Then go tu your Documents directory (user/xxx/Documents)
  3. Create directory named “Unreal Projects” here.
  4. Now you can move any of your actuall projects here
  5. Restart Epic Launcher
  6. Now Epic Launcher will detect your project just like on Windows and you will be able to add your assets.
    It is as simple as that what is even better is that instead of copying your project to Epic Launcher filesystem you can just symlink it there, so you can seamlessy add anything to your project whenever you need. Really simple and perfect solution.

This worked great for me: GitHub - nmrugg/UE4Launcher: The Unofficial Cross-Platform UE4 Launcher

I didn’t bother trying to add UE5 to the launcher, but it flawlessly integrated my marketplace downloads into my saved UE5 project, which is really all I need.