Download link for vs2013 express doesnt work?

I have tried for the last several weeks to download vs2013 express using all available legal means. Install program doesn’t download (*.EXE fails at 30% downloaded) - No iso links I have found work.- virtually all IOS links to express 2013 seem to have vanished. “Can’t find page” <-message from Microsoft’s site.

Machines are Win7 32bit, Win7 64 bit. Identical failure pattern both machines. Crashes at 1.7meg when using a Linux machine to try to grab the ISO

Help would be greatly appreciated. Even had MS tech do a remote in - worthless except to recommend I spend money on upgraded internet connection.

All aid is appreciated.

Use this:

dies exactly the same way - at 28%. Were you able to download the entire *.exe and then start the download? This is happening with both Win7 32 and 64 bit, and a Linux machine (tried to grab the iso to do the offline install) - all die the same way. Please verify link works for you.

I was able to download the exe in no more than 2 seconds. Its 1.2 MB. Just a shot in the dark here: are you using Peer Block? Also have you googled for offline installers?

No peer block. I have Bellsouth DSL, and my Ethernet cable from my PC runs runs straight to my router. If 1 machine was screwy I would understand - but 2 x Win and 1 Linux? - when I can literally download anything else legal?-
BTW - cant download vs2012 update 4 either. makes no sense to me.
Heck, I just finished downloading Unreal engine 4.6 so I can use my existing VS 2012 install to start playing with C++.I even changed out the switch I was using in case it had a bad port (glitch etc) - same behavior.
I really don’t know the frack is going on.

Hey everyone who bothered to look… managed to fix this weird as heck stuff!!!
Used a mobile Broadband connection to get the exe that launches the install. Apparently once that was downloaded it is smooth sailing. Currently downloading on 2 PC’s that barfed earlier.

THANKS for caring enough to try.