Download infinitely restarting

During that time, it may restart a couple times, but the QFE2 hotfix will ensure it only restarts the files that it found to be incorrect.

Also, to let you know, there is a ‘retry’ limit, so it will only restart a few times in a row to try and get a full install correct. If it fails after 5 attempts then you will see an error message.

Let us know how you get on and upload the logs from this process I can help some more if it is still no good.

All I have done is with the QFE2 fix you provided below, if I dont do this, I cant run the engine, and still keeps downloading forever and I cannot open the engine.

Ahh ok. A of your logs folder would be great then. It may have info to help see why yours is failing. Just to confirm, were you able to allow launcher on QFE2 to keep trying until it presented an error message? I understand that it is frustrating I’m sorry about this.

Logs folder:-


Sorry, were there more files than that in the folder? If i am to help I will need to see a log that was generated from a full install attempt. (i.e when you have time to close the editor for a while, just let launcher try its best uninterrupted until it finishes trying or you get an error message). That one is a log that is from a download being canceled after a few minutes. There’s no hurry if you are happy as is for the time being :slight_smile:

Uninterrupted Crash

link text

Thank you :). That’s very peculiar that only a bunch of png files are not being created correctly. I can try and track this down now I have the info.

Thank you so much !
Live up to your name :slight_smile:

Unfortunately I won’t be able to help :frowning: I’ve already downloaded it twice while trying to get it to work and as I said in my original post I have a limit on my downloads and if I go over it I’ll literally have dial-up speeds for the remainder of the month which sucks a lot :\ There’s three other people in my house using it as well :\ sorry :\

EDIT: Gah, now my editor crashes on startup after I tried to import an .fbx, likely something to do with the corrupted files. I think I might have to wait until a launcher patch that repairs an already installed installation.

Forget about this, it was more trouble that I had thought it would be. The disk space associated with my user account is no longer available from the Unreal Editor. When I try saving to it, I get nothing, guess its probably locked somehow. On the other hand, when I try saving to this “super user mode”'s user space I can’t access its files from the finder no matter what I try. Its hidden location goes something like this

–to be continued

–continue reading

“/Volumes/MacOSXDisk/private/var/root”. Now, I’m even struggling wanting to erase this stuff from there because it takes so much space on my SSD and I don’t know how to access that folder…

Well, I guess I’ll just have to wait for you to push a new patch or something. Anyways, sorry for the let down.
Here are the answers you requested:

–to be continued

–continue reading

  • My usual user account is the only user account on my machine (the one I added right after the OS setup). I don’t understand what else you want me to say about it, please clarify.
  • I installed the launcher from this one user account alright.
  • My home folder is on another disk. I used the classical method to make it so (right click on the user account in system prefs, change location, then ).
  • I didn’t touch the permissions when I moved my home directory around. Heres what the finder tells me about that folder (me: RW, staff: R, Everyone: R).

Hope this helped.

@StephenEllis reading closer my problem is when the editor is updating, not when trying a download. Sorry.


Are your downloads still restarting after they complete?

What is your Launcher version number? (located in the bottom-left corner of the Launcher)

@gwoodruf (in response to your edit)

Okay. Please search for other posts related to your issue, and if I cannot find any, we suggest you make a new post.


I am having the exact same issue as J_U_D_G_E where I have tried adding “-CPLabel=QFE2” to the shortcut but received an error “Unlisted build label QFE2”

i would like to be informed when a fix for this will happen.

link text


Which version of the Launcher are you currently using? (displayed in the bottom-left corner)

Assuming you are on a more recent version than was being used late March, the QFE2 would be of no benefit, as the fix it contained has already been rolled into the latest versions.

Hi mykdragn. Is your problem that the “Unlisted build label QFE2” message appears? Or something else?

The QFE2 hotfix no longer exists as that is now in the main release, you should be running without any extra commandline options :slight_smile:

On closer inspection, I can see in one of your log files that when trying to install the engine, a whole bunch of png files fail to save out correctly. It strikes me as a bit odd that only png files would fail and nothing else :). Do you have any virus protection or data monitor programs running, like Panda Cloud Antivirus? Perhaps they could be interfering with the installation of the UI content for some obscure reason.

It does look like each time the installation got further and further though, down to just 15 png files failing on the final attempt. There is a quick hack that you can do to force the patcher to keep attempting to resume from the data currently contained in the installation folder. In your case I believe the steps will be as follows:-

  1. Navigate to “D:/unreal/4.0/”
  2. Create a new file named “$movedMarker”. This file should have no extension (yes, that’s a dollar sign!)
  3. You now have the following empty file “D:/unreal/4.0/$movedMarker”

You will need to do that just before starting the download again.

If successful, when you click install for UE 4.0, the process should begin with “Verifying Installation” and will then only attempt to download and install the png files that are still missing or corrupt. If this worked then you should notice that the downloading after verifying does not need to get the full 7.7GB.

Let us know how you get on, and please upload zipped logs folder again if you are still having no luck.

Thanks for your patience

Thank you that worked perfectly.