Download infinitely restarting

So I’ve been trying to get this to work but no luck so far. Basically what’s happening is that it’s completing the download and then as soon as it’s finished it goes back to 0% and restarts. I tested it with Swing Ninja from the marketplace since it’s only 97mb which is tiny compared to everything else and it just keeps going and going and going.

I could just keep trying until it works but I have a monthly download limit that I’d rather not breach (Downloading ue4 has probably already screwed me for this month but I’d rather not get more screwed :P)

Hi leonn3k,

Sorry to hear you’re having issues. I could do with seeing some of your log files if that’s ok.

You can find them here:-

C:\Users\User.Name\AppData\Local\UnrealEngineLauncher\Saved\Logs

Replace User.Name with your windows login name, and attach a zip of the log files you find in there.

Thanks,

Leigh

Hi Leigh, Thanks for the reply. I’ve attached the log files as you asked. link text

I have the same problem with launcher restarting the download after completion on OS X too. I’ve downloaded the ~6gb content which starts automatically multiple times. First time: ERROR: Failed to construct file UE4Game-Redist-Engine-Mac-Shipping.a
second time: Verify failed on UE4Game-Redist-Engine-Mac-Shipping.a
next try: Verify failed on UE4Game-IOS-Shipping
and last time: Verify failed on UE4Game-Redist-CrashTracker-IOS-Shipping.a

Hey, just to update you, thanks for the logs, i’m looking into the issue now to see if i can come up with some suggestions for you.

However there is a known issue at the moment that when certain types of problems occur, we are seeing the whole download retry, instead of just the failed files. I think you are seeing this issue, which looks like infinite loop of downloading.

It looks like some of the patch data being downloaded is arriving corrupt.

(see log output that states “VerifyChunkFile chunk hashcheck failed” and “Failed to uncompress chunk data”)

Have you got any further yet?

Hi, not sure if it is the same. My downloads do finish every time but the install fails saying exactly:
Install Failed - A file access error has occurred. Please check your running processes.
I’m on Mac OSX 10.9.2 up to date.
My home folder is on an separate disk from my OS. Not sure if this changes anything…

I think this issue may be related to having user documents on a different volume to the launcher install. Does that apply to you? I’m investigating this too.

This applies to me yes. I’ve just tried putting the launcher on my Documents disk (home folder, I’m on OSX) but unfortunately it does not change a thing… So maybe my issue is the same as this thread’s no?

Sounds like it is related, unfortunately I haven’t got to try to reproduce yet, but we are working on an attempt to fix the issue regarding different volumes.

Ok, I have a fix for the problem with restarting downloads and chunk hash fails stalling the process. Try these steps to get the latest hotfix and let us know how you get on.

Please locate your desktop shortcut, and in the properties for the “Target:” box, add “-CPLabel=QFE2” to the end noting that QFE2 has to be capitalized.

The whole setting should look something like:

“C:\Program Files\Unreal Engine\Launcher\Engine\Binaries\Win64\UnrealEngineLauncher.exe” -CPLabel=QFE2

Please reply to this post with new logs if you still have problems.

Thanks!
Leigh

On Mac OSX, I dug a little more and this is the kind of log I get:

MoveFile was unable to move ‘/Users/Shared/UnrealEngine/…SomeFiles’ to ‘/Volumes/myDisk/Username/Documents/Unreal Projects/…SomeFiles’, retrying in .5s…

This is why the install fails every time. Do you have a workaround for this?
I already have my home directory on an other disk and I don’t plan on putting everything back into the system, it would be a mess…

Did this fix, now the Engine… Finishes downloading.

However, it crashes at the very beginning of the install, and now, after the crash… well… it starts downloading again.

I am installing on a Different Disk, like Altares is doing.

Hey thanks, altares.

Yea we know the issue and a fix is in the pipeline.

I’m afraid a similar process to the windows one mentioned above is not available to OSX yet, until the next Launcher update release. This should be quite soon though!

Sorry again for the inconvenience. We are trying to see if there is a quicker way to hotfix individual OSX users and will update if we find one!

Ok found a workaround.
One needs to sudo the Launcher in the terminal every time to start the engine or download contents. If one tries calling the app directly Mac OS style, he loses everything.
At least for now, it WORKS!
Sheers

Hi Leigh, I tried it and it didn’t end up working unfortunately. I have managed to get it working by starting the launcher and stopping all of the downloads then going into C:\Program Files\Unreal Engine\4.0\Engine\Binaries\Win64 and launching UE4Editor.exe from there. If the launcher isn’t open then running the editor .exe just opens the launcher. It’s not optimal but it’s working for now.

Ahh that’s interesting, thanks for sharing! So it was sort of a permissions issue in the end. It’d be great if you could help to specify a setup we might be able to reproduce this with.

What type of user account did you install the dmg from?
Is that the same user account you then started using the Launcher from?
Does your documents/home volume have different permission setup?

Thanks!
Leigh

Hi again J_U_D_G_E. Sorry to hear that, are you running Mac or Windows?

Hi leonn3k. Glad you are up and running. It does worry me a little that you may be running an editor with some corrupt file in it which is why the launcher has been retrying. You should be a little careful with saving often :). The fix in this QFE2 should mean that when the download/install appears to restart, it will only then fetch the files that were broken and so should finish off better.

Would you mind uploading some new logs after running the QFE2 version?

Hey Swifty, Im runningon Windows.

I was reading another thread, and it seems to be a Launcher issue.
I went into the Folder Structure, and was able to launch the Engine, by clicking on the .exe

Seems to be a launcher issue!

At this time though, every time I open the editor, I have to cancel the launcher since it tries to re-download again.

Yes what you are launching there inside of the \4.0\ folder are files that the launcher has created so far, i do worry that it does mean you may not have the exact correct copy of the editor in there that you need and may be extra unstable.

It’s great that you are managing to launch the editor though. But i’d really like to get you to a point where the launcher has synced it up properly :).

Do you think that at some point, when convenient, you could make sure the editor is not running, and then run the QFE2 hotfix and allow it to try and complete the install process without cancelling?