Download hangs on slow connection

I searched answerhub and found other download issues, but none the same as this. I’m trying to download UE4, and after getting to about 2% (it’s not the same every time), the download goes to 0 kbps. It very occasionally restarts, but never for more than a second. I’ve cancelled and restarted several times and had the same issue every time.

This is similar to this question (Problem Downloading UE - Installation & Setup - Unreal Engine Forums) but not similar to the one linked in its answer (Download infinitely restarting - Getting Started & Setup - Unreal Engine Forums) since my dl never finishes, it just stops.

I noticed you asking for the install log in other questions so here (with the launcher still open and trying to download).

This happens on other downloads (e.g. Firefox downloads) for me as well but pausing/resuming those generally fixes the problem. It does nothing for UE. It’s not a connection issue, and I have restarted the launcher and rebooted my PC.

[edit] trying this fix [Official] Read this if your Download has stopped around 81% - Getting Started & Setup - Unreal Engine Forums

Hi Shivan,
Have you got any further with the download? The log file you pasted shows that some data downloads are failing after about 5 minutes. Often these issues with download speed can be fixed with the ini file changes mentioned in the post you linked to.

Could you also try to download this following link, and let me know also how long it takes if successful? It’s one of the data pieces listed in your log as failing.

On the “Read this if your Download has stopped around 81%” answer, could you do both ini changes, for the timeout increases and the logging. Then could you run the launcher and try again, but leave it trying to download for as long as you can (overnight if possible) or until you get an error displayed on screen. After that, please close the launcher, and then upload a zip of your logs folder (not just the latest one).

It’s important to get logs after closing the Launcher otherwise they can be somewhat incomplete.

Hopefully that will help me identify if you are having any other issue, but I suspect it is mostly to do with your download speed, which we can try to work around instead.


Thanks for the response! I attached some logs to my answer to that other question, but I think some of them had incorrect logging options causing the launcher not to log as much as it should (and only one got as far as an error). I’m trying again with the correct settings (and the exact numbers in the timeout settings, not the ridiculous ones I tried), and I’ll upload my logs tomorrow.

As I said, I’ll have faster Internet in about a week, so it’s only a real problem if I still can’t get it then.

Also, that chunk you linked downloads almost instantly in Firefox and Chromium for me (which makes sense because it’s ~300 KB). But the log I’m generating now seems to be having trouble with the same one again. Odd.

edit: I have a complete log with both fixes. It’s too big to upload on answerhub apparently, so I put it on my account here. This goes until I get the “could not download patch data” error.

Hi Shivan, sorry for the delayed response. I’m afraid I’ve not managed to get very far with trying to figure out exactly what you could try. You seem to be getting periodic downloads that just hang for a long time until receiving the error code

The connection with the server has been reset.

Sometimes they eventually succeed and the install process continues, and sometimes they fail too many times in a row and the process aborts.

Perhaps your connection is not happy with the number of simultaneous requests. There are some more ini file settings you could have a go at if you like! Try this:-


Add those lines to the end of the same DefaultEngine.ini file that the HTTP ones went into.

ChunkDownloads there is the number of downloads to run simultaneously, you could even try 1 meaning just one at a time, but that usually means you suffer more from the overheads of making internet requests and your overall speed will be lower.

Hope that helps!

Looks like that worked. I have the engine, and I’m (slowly) getting some content examples now. Thanks!