Download

Double & flickering foliage issue (City Park example) [UPDATED - 1/2 fixed]

Hi, guys;
Been testing the limits of ray-tracing in the city park outdoor scene and I’ve now got double foliage in the viewport and in my renders (incl. Movie Render Que).

https://youtube.com/watch?v=2yCtKiyiTa4

It seems like there’s a non-animated clone sitting alongside the animated vegetation. What’s up with that?

It’s not a case of duplicate actors as deleting any of the affected assets removes the clone. Am I missing something here?

Update:
Opening a copy of the project with 4.26 seems to have removed the issue. Therefore, I assume this was a bug that manifested at some point in the level.

I now need to identify what is causing the flickering/shimmering as shown in the grass here.

https://www.youtube.com/watch?v=rS9WzJ3I60M

Due to deep technical limitations, ray tracing can’t really render WPO which is used for animation here. So I assume that Epic’s workaround for this limitation is to use meshes without WPO for ray traced calculations. And it seems like you have done something, or some bug occurred which resulted in those non-WPO stand-ins for ray tracing being visible. Kind of a funny bug, but still most likely a bug non the less. :slight_smile:

Maybe this can help you?

Did you enable “Evaluate World Position Offset” in every static mesh? It’s under Rendering > Ray Tracing. Look at the answer to the following AnswerHub post:

https://answers.unrealengine.com/questions/967700/view.html

Thanks for the suggestions guys. I’ve fixed the issue by opening a copy of the project in 4.26; though I suspect making a copy in 4.25 would have also solved the issue, as it seems like a bug.

I’m now trying to tackle the issue of flickering/shimmering foliage, as seen in the grass here… any ideas what this is?

https://youtube.com/watch?v=rS9WzJ3I60M

Distance field shadows need disabled on the foliage perhaps?

flickeringfoliageexample.jpg

Looks like a culling / rendering issue, though it could be distance field shadows too or exclusively. There’s different ways of culling, and if the foliage is being grouped for culling, then it would appear to be the problem as the shimmering pieces are spread out in different areas. Try increasing number of instances of foliage per group in culling settings, so it allows for more foliage before culling is initiated. And try changing the distance settings for culling.

What distance field shadows are being used in the scene? Only the directional light’s or the skylight DF ambient occlusion too?

If you use ray tracing then this is expected. RT performance is still nowhere near sufficient to handle dense detailed geometry, such as foliage. Foliage is still one of the worst case scenarios for ray tracing, where denoiser can’t really do proper job, especially in temporal dimension, just due to how fine the geometry is. When you have tons of super fine grass blades, denoiser still needs to honor the normal threshold, so that it doesn’t blur surrounding surfaces which are not connected or separated by a sharp angle. This means that the individual contiguous areas pixels can be averaged within are so tiny there’s just not enough pixel information from just a few rays to have anywhere near stable result.

If I am right is very easy to verify, just turn off ray tracing (reflections, AO, GI, everything) and see if the problem persists.

Have you tried disabling Sky denoiser? (Or maybe AO denoiser, GI, denoiser… but I think it’s Sky’s)

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_210533_1609383105785_339”,“title”:“01.jpg”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_210531_1609383011480_249”,“title”:“05.jpg”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_210532_1609383060318_822”,“title”:“06.jpg”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64

[ATTACH=JSON]{“data-align”:“none”,“data-size”:“full”,“data-tempid”:“temp_210534_1609384218914_724”,“title”:“10.jpg”}[/ATTACH]
https://forums.unrealengine.com/core/image/gif;base64
​When ray tracing is turned on in ue4.26, the dynamic effect of wind of foliage will greatly affect the UE performance,and the foliage has double mesh and the shadow is wried:
In UE landscep scene, when there are a lot of wind blowing grass, if you turn on ray tracing, the performance will be greatly reduced. I’ve tried many ways to turn off the ray tracing effect, but it’s still useless. I have to use Ue4.26’s gpulightmass bakes the light, so the Ray tracing must be turned on in the project. There is no way to turn it off, so you have to manually enter the command in CMD,like **r.raytracing.ForceAllRayTracingEffects 0.Or turn of **Vegetation’s wind dynamic effect.If someone know the resolution ,please tell us.thanks.

yes,you are right,I try many way ,only use [FONT=等线]r.raytracing.ForceAllRayTracingEffects 0,unless you use static foliage in a Archinteriors scene.