DK2 Vsync drops frames by 3x

link textI finally tracked a problem with my framerate being locked to about 35-39fps down to vsync. It doesn’t have anything to do with the quality settings and changing them does nothing at all it just seems to be stuck at this rate. An empty scene is the same as couch knights even on the lowest graphics settings. The only thing that helps is when I run “hmd vsync off” I get a jump of about 3x or more depending on the graphics settings.

Why is vsync working contrary to the way I think it should :if fps is lower than 75 it should drop to the next support refresh rate of monitor but otherwise should stay at 75? Am I missing something?

If there any workaround? I have tried everything in the forums running hmd sp 80 at startup nothing fixes it.
I have keys mapped to the graphics settings and the only time it will ever go back to 75 if is I toggle through them really fast but I’m guessing this is probably the fps counter resetting and stabilizing.

Also I have a toggle for low persistence setup to a key. Even though I am not getting more than 39fps I can still enable and disable low persistence which I didn’t think worked below 75. It is actually working the screen gets darker when enabled and things are not very blurry when it is enabled. That said things are still choppy and it is clearly running at the 34-39 fps. I thought I would mention this for reference.

My specs: 4790k, 2 x 760GTX (SLI turned off), 16GB ram, SSDs, Windows 7
Oculus SDK 0.4.2
UE4: 4.4.3

Also I have disabled mirror which doesn’t drop the frame rate a bit. I have turned off frame smoothing and set minimum desired frame rate at 75 and many other numbers higher than that with no change. I have tried setting performance settings at runtime (as they seem to reset when you go fullscreen) chaning everything except resolutionquality as that seems to lock up when I try to set it). In fact the only thing I can get to drop the framerate below the 34-39 range is raising the hmd sp to something crazy high like 300.

Hi BlueByLiquid,

Thank you for posting your specs, but could you also post your dxdiag?

While testing this I would get about 60-68 fps with ‘vsync on’ and about 70-78 with ‘vsync off’. However, while vsync was turned off I would get pretty bad vertical artifacting while looking around. Do you also see any vertical artifacting/clipping while vsync is turned off?

Thanks TJ. Depending on the settings I can get as much as 140fps with vsync off in stereo. With vsync off everything scales as you would think (as I increase quality settings things get slower) but for a blank project with just a floor and a character it doesn’t go below about 80-85 with vsync off.

I have attached the dxdiag to the original post

As a last ditch effort to determine if it had anything to do with not haven’t enough graphical horse power I overclocked my GPU. Fps again went up as expected 25fps in regular mode but when I turn on stereo again it is that same 34-39fps. Disabling hmd vsync shows that I am getting a 13-15fps just in stereo mode after overclock but again it is over 75fps. Any other ideas???

Oh and yes TJ I do see vertical artifact/clipping when vsync is off.

So I have finally found the issue. ARRRGGHHH!

It seems that Actual Multiple Monitors is having some conflict specifically with the rift vsync. Killing it makes fps jump back up as expected. It seems this might also be causing some other issues I have been having as well.

The Actual Multiple Monitors product is pretty sweet (adds taskmanager AND start menu to each monitor and only displays windows on the task manager for the monitor they are on. I have become to rely on it for using multiple monitors as the other solutions don’t work as well and none add a second exact copy of the start menu. and other items. here is there site: Actual Multiple Monitors: Extended Taskbar with Support of All Windows 7 Features on Each Display. While there site looks pretty crappy their products are very good.

I will submit a ticket with them on the issue as well. It would be interesting to see what the conflict is. I’m guessing both the oculus SDK and AMM talk to windows at a very level so maybe they are walking on each others toes.

You guys might make a note as many developers I know use AMM for multi-monitor setup so they will likely have similar issues.