DK2 VR Preview Greyed out 4.8 preview 3

I have DK2, windows 8.1. The VR preview button is greyed out and I can’t view in VR mode on ue4.8 preview3. I confirmed that I can press the VR preview button on my older projects in ue4.7.6. I even created an empty template in 4.8 preview3 and the VR preview button is still greyed out.

I even opened a copy of the project in ue 4.7.6 and the VR preview button worked.

is there anyway to go back to preview 2?
I think it worked in that build.

Hello unrealChris,

I was unable to reproduce this issue one our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Are you currently using a Mac?
  2. Could you make sure that your Oculus runtime is up to date?
  3. Does running the project in Stand alone mode and using the shortcut Alt+ Enter bring up VR mode?

Im using windows 8.1
I was using oculus sdk
I upgraded to sdk 0.6.0 and the button became available, however the oculus kept crashing. However, I think this is a sdk bug because it was crashing while trying to view the demo scene provided by oculus in the config program.
Alt+ Enter in standalone mode did nothing.

In “Standalone Game” mode the screen becomes black when I enable “Stereo on”.
Preview mode works fine.
Running Windows 8 Oculus SDK 6.0.0

Hello unrealChris,

Does switching your display mode to extended mode make any difference when it comes to crashing?

Hello unrealChris,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

So I thought it was the Oculus 0.6.0 runtime causing problems on my windows 8.1 laptop because I couldn’t run the demo in the OculusConfigurationUtility.

However, although I could press the VR preview button on ue4.8 preview 3, it would just show a white screen, the oculus service would crash (as shown by the oculus utility program), then the game would run in non-vr mode. I ran the same project on ue4.7.6 and was able to get VR preview to work with runtime 0.6.0.

Extended mode makes no difference.

Actually I just got an orange screen that says
“Application is paused while an old SDK is rendering.”
This was in ue4.8 while I still had the same project open in 4.7.6.

Hello unrealChris,

I was able to reproduce this issue on our end. I have written up a report ( UE-16171) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your information and time.

Make it a great day

Would just like to add that this is a showstopper for us. We cannot move onto 4.8 (which is desperately need to for stability), if VR is busted. It is still busted in preview 4, just to let you know.


I am having the same issue with 4.8 preview 4

The orange scereen means that you are running old 0.5-based app simultaneously with the 0.6-based one. You can run multiple 0.6-based apps, but only one 0.5.
UE 4.8 Preview 3 switched from 0.5 sdk to 0.6. Preview 2 was using 0.5. So, if you are on 0.6 Runtime you need to use Preview 3 and later.
If you are switching to 4.8 Preview 3+ you must install 0.6.x Oculus Runtime.
You also can’t run old UE 4.7 (which is 0.5 based) simultaneously with the Demo scene in Oculus Config tool (if you have 0.6 Runtime installed).

That makes a lot of sense in hindsight.

In 4.8 Oculus just crashes either the Editor or the Game using Runtime 0.6.0

Make sure the service is running (by opening Config Tool and opening the Demo Scene).