Download

DK2 Performance Regression with 4.8.2?

Can anyone tell me if they see a significant drop in performance after updating their project from 4.8.1 to 4.8.2, too?

Unfortunately I can’t go back to 4.8.1 within the launcher and can not confirm it myself.

this scene was doing fine before the upgrade. now it’s choppy. can anyone tell me why the CPU is stalling all the time? I’m no expert at reading the profiler stuff :frowning:

gamethread.jpg

a426f0ae803b45126afcbf0f1035e9b55f5addfe.jpeg

Did you upgrade to Oculus Runtime 0.6.0.1? If so, try console command ‘hmd qahead on’.

All the stalls are maybe not the real problem, it could just be the - now forced - V-Sync.

hi spyro, i have the 0.6.0.1 runtime and qahead is activated :frowning:

Any chance you can post the .ue4stats file?

@Opamp77: unfortunately not (even if I would like to)

day 2 of the hunt for performance: I migrated the Map (and thus all its content) to a blank new 4.8.2 project: and it runs smooth as butter as before (constant 75 fps).
Then I deleted (again) the Intermediate and the Saved folder of the original project. But no luck - still performance issues.

Where else does UE4 put cached files that need to be deleted for it to think that this is all new? what folders do I have to delete?

edit:
it seems to be connected to a plugin. if the plugin never existed, everything runs smooth. if the plugin is added, performance drops. if plugin is removed and caches are deleted, perfomance stays low… :confused:

The only Oculus related stuff that i know off in those folders would be within engine.ini in the saved folder which holds some of the oculus settings. See LoadFromIni() / SaveTonIni() in OculusRiftHMD.cpp…

What plugin are you talking about?

Hi Opamp77,

thanks for your help.
The issue was located somewhere else: we had a movie playing on one texture. Though the mesh with the texture was removed while searching for the cause of the hiccups, the movie kept playing in the background (in the content browser you could see it playing).

Disabling the movie alltogether brought back the earlier performance.

So this performance issue was not related to Oculus. I’m marking this as solved.

Thanks all for your help!