Download

Distortion on object edges when they are in motion / when the player is in motion in VR UE4

Hello,

Unfortunately it’s hard to get a video/series of screenshots to show the problem as it seems to be a problem purely inside of the VR headset. The best way to describe the problem is that the space is warped around the edges of objects when they are either 1. moving or 2. the player is moving.

We have had this problem for a few months now and have not made any progress on a solution for it.

We have tried -

  • Deleting everything from the scene for testing whether it’s a FPS related issue
  • Removing Fog/Atmospheric Fog
  • Changing lighting properties from Directional to Static
  • Trying a multitude of Depth of Field properties to see whether the issue is a render priority problem
  • Removing translucency/particles from the scene
  • Importing optimal VR project properties provided by UE4 documentation
  • Tried changing a multitude of features in the character camera settings to no success
  • Made sure there was no Motion Blue on in the project settings and in post process settings
  • Tried forward shading
  • Tried all Anti-Aliasing options including Temporal AA with up-sampling option
  • Tried changing Screen Percentage/VR pixel density options to smaller and larger values
  • Turning post process volumes project wide OFF
  • Tried multiple VR headsets and computers to see if it could be a problem confined to hardware
  • Turning distance fields on/off

Although we have tried all of these, please do recommend a solution if it fits under any, as it may be a small detail that we may have missed.

Thanks,

Joshua Chaplin
VR Environment Artist @ The Dream Corporation

Did you try testing the same project on a different system, possibly Oculus? Did you try to display the HUD diagnostic inside the HMD to make sure it is not a tracking/HMD performance issue?

Beside what I mentioned above, you should also test the standard VR template that comes with the engine and check whether you see the same effect there are well. That template contains most of the optimizations you want for a VR project.

SOLVED

It ended up being a driver issue, I have rolled my driver all the way back to the oldest possible version and this completely eradicates the problem!

happiness

Which driver version did you end up using?

We are also seeing this, but so far only on the weaker laptop with 1070, not on the stronger stationary machines.

I believe this is SteamVR’s new smoothing algorithm for when you can’t hit 90 in the headset. I think I’ve read that John Carmack did something similar for the Rift view, and Valve seems to have refined this to actually work on individual objects and not just the entire view.

I’m seeing this exact thing, and have been doing online searches to try and find a resolution.

So far I’ve seen:

  • It does it on my local machine, running in VR Mode in Editor. Windows 10
  • The game packaged and running on a different machine doesn’t show it. But that machine is Windows 7.

Does anyone have any further info on this problem? And how to stop it?

My NVIDIA driver is:
441.28

Motion Smoothing seemed to be the issue, reverting back to an older driver got rid of the problem. Apologies for such a delayed response, a while since I’ve been on here.

If still having issues I would recommend playing with the Motion Smoothing setting in SteamVR -> Developer.

Good luck!