Download

Distance field shadows not working with directional lights

Ray traced distance field shadows works perfectly using point lights but as soon as i am using directional lights i am getting no shadows at all unless i use the other techniques, i do not know what i am doing wrong and i have searched the forums and used google but nothing comes up regarding this issue.

http://i60.tinypic.com/13z4lx.png

I’m having the same problem. Works perfectly with a point light, but nothing with a directional light.

How about making light point?
I was have same problem at sincely. make the light point, everyth

Are you sure it’s not because of the viewmode? Maybe it only shows up in detail lighting or lit mode?

It is probably because of the “DistanceField Shadow Distance” value that you have set. It is quite high.

You should reset it to the default value, and the shadows should work.

Same results no matter what view mode is selected.

Tried all the settings available for distance field shadows in the directional light. None of them fix the problem.

Again, point lights and spot lights work perfectly fine. Only directional lights are having this issue.

I’m facing the same issue with 4.9. On 4.8 there is an Answerhub thingy regarding this issue: Distance Field Shadows not working with directional lights - UE4 AnswerHub

My guess is that directional lights rays are all parallel and therefore only one, infinite, or no mesh is built. I think the point lights have a radius that helps determine the trailing angles from which the meshes are built.

Just wanted to comment here that this is currently being looked into. It does appear to be affecting those using Radeon series cards that I can see. Specifically the one’s that have been in the DxDiags have been 200 series with Driver 15.20.1062.1004.

Ticket UE-20358 has been submitted to investigate this. I’ve linked this post and two other AnswerHub posts to the ticket. I will update once a solution has been found.

In the meantime, if anyone reverts to an older driver or has an older driver that this is currently working on as intended can you please post and let me know. I can add this information to the ticket.

If anyone needs a sample project to test you can grab it here: https://answers.unrealengine.com/storage/temp/55572-df_test.zip

Thank you!

Tim

Thanks Tim. I can confirm this issue with Unreal 4.9 Preview 4 on Nvidia GTX 660M (latest WHQL), Windows 10, DX12 in editor …The DF shadow only seems to work when I set the distance to start between 500-1000.

Hi Srmojuze,

I had not previously seen any reports of this with users with Win 10.

  • Can you post your DxDiag here?

We only have a single machine setup with Win10 at the moment, but I’ll see if we can test on this. Before doing that though can you test the following things and let me know what you’re seeing.

  • If you disable DX12 does this resolve the problem? DX12 is still considered experimental and if we can rule out this being an issue with that, that would be good to know.
  • You mention the 500-1000 range. Did you use the test project I linked above? If this is happening in DX12 but not in the Default DX11 let me know this as well.

If you test this in my sample project, this is setup to only use DFs for Directional and Point lights with a separate map for each.

Let me know and I can run a test with our Win10 machine to see if I can reproduce with or without DX12, then I can update the ticket to include what I find.

Thank you!

Tim

Hi Tim,

Thought maybe you’d like to see my DxDiag as well…I’m on Windows 10 having the same problem. Had the same problem when I was on Windows 7 as well, so I’m not sure it’s a DX12 issue. (Not sure how to disable DX12 honestly)

I’ve tried the project you linked, and still get the same results.

I also tried playing around with the DF shadows range like Srmojuze suggested. It didn’t have any effect for me in 4.8…However, I tried it in 4.7 as well and it actually did fix the shadows when the range was reduced to about 20,000 or less.

Thanks, bdurar!

Looking at your DxDiag, this appears to be the same issue that other AMD Radeon cards are seeing. The Windows 10 connection was really only meant for srmojuze since the specs mentioned do not include a Radeon GPU, but instead a GTX which I’ve not seen any issues with thus far.

As for DX12, if you’ve not enabled it on UE4 in Windows 10 then you’re still using DX11. DX12 is still really experimental and can only be enabled via command line.

Ah OK it’s DX12. On DX11 everything works fine. On DX12 it does not work.

My DXDiag as attached.

DX11 (OK) and DX12 (issue) tested with Unreal Engine 4.9 Preview 4.

No worries, just another thing to add to the 4.9 list :slight_smile:

Thanks,
srmojuze.

I have the same problem using R9 270.

I do not think a lot of heavy testing has gone into DX12 so that is why something might not be working as intended.