Download

Distance field shadows have some sort of low res 'box' around them in UE5

Don’t really know how else to word this, in UE4 I spent a lot of time upping the resolution on my trees to make the distance field shadows look halfway decent, in UE5 they’re still visible but inside this sort of ‘shadow box’ that really gets in the way, I’ve looked at everything and all my settings are the same, regenerating distance fields doesn’t change it either

in UE5:

UE4 comparison:

distancefieldue4

Any known issue or some sort of change that would cause this?

Did you find the issue?
I’m currently running into the same issue.

are those nanite enabled meshes?

I’m pretty sure I don’t have nanite enabled on any meshes at all, will double check if I try UE5 again though

Did this happen with all meshes or just ones with masked materials?

Is it just me or does it appear to be rendering the collision box in the shadow?

Here’s a gif of the distance field that’s been generated…

I don’t think it’s related to the collision, i imported a custom collision mesh just to be sure…

image

Yeah that doesn’t look good. No idea what could be causing that. Seems like you should report this as a bug…

for what it’s worth I already reported it on my end (Case # 00332798), don’t believe it ever got a follow up or a filed issue but if @Kield has more info on reproducing it (i couldn’t fully reproduce it as my project is pretty complicated and it wasn’t always doing it for me) then it’s probably worth a resubmission for sure, it looks like the exact issue I’m having

I don’t think anyone ever does