Download

Distance field Shadows don't work

https://answers.unrealengine.com/storage/temp/83157-untitled.png

As you can see, I have a simple post in the level, that has no shadow at all. Cascades are completely turned off, and distance field shadows are turned on.

https://answers.unrealengine.com/storage/temp/83158-2.png

This is a screenshot of the distance field mesh(using the visualizer).

So, I have no idea what is wrong. The mesh is good, what could possible be wrong?

Also: I have a GTX 760 card, so its not even an AMD (Heard there were problems with that)

hi noatom,

have you turned on the “generate mesh distance fields” in the projects settings/rendering?

yes it’s turned on

UPDATE:

I just realized, distance field shadows work, but only on Epic quality, not even on High. Is this normal?

Hi noatom,

This is expected. It requires SM5 to work and that’s only supported with Epic Quality Setting. IIRC this is mentioned in the documentation for Distance Field AO and Distance Field Soft Shadows as well.

Tim