Download

Distance Field Shadows and Skeletal Mesh

I have a dim interior scene in an abandoned warehouse and I have enabled distance field shadows so I can get nice soft shadows from the surrounding meshes.
I have found though that as soon as I enable distance field shadows on my spot lights (the only light type I am using), my character shadow disappears.

I think I have clicked just about every button and checkbox on the light and skeletal mesh for the character but despite everything, I cannot get the character shadow to show when I distance field shadows turned on.

If I turn off the distance field shadows setting on the lights I get my character shadow back but the shadows are all hard edged and not soft like I want.

Can we have distance field shadows and also shadows from skeletal meshes.

PS. I am using UE5EA but the exact same issue in 4.26.2 so I am thinking I am missing a critical setting somewhere.

Thanks in advance.

Completely impossible due to distancefields being literally impossible to do on skeletal meshes. Maybe a mixed df+capsule shadow method will be applicable?

1 Like

Hey @Bits360 thanks for jumping in with the advice, I figured this was the case :frowning: .

I think I have found a slight alternative that I don’t think is as good a distance field shadows but still seems to help with making shadows softer - that is by increaseing the source radius and soft source radius of the spot light… it does soften the edges of the shadows enough to at least make them look close to what I wanted to achieve.

I appreicate you chiming in though :slight_smile: