Distance field and landscapes

For some reason distance field showing artifacts when too close to a landscape, It’s looks like random squares…
In the mesh distance field the landscape is black, But it’s showing in distance field AO with the artifacts…
Also I tested it with just new landscape and skylight in the map and it’s doing the same thing…
I tested it with 4.13 to 4.14.3, And if I remember currently I even had it with 4.8-4.9.
My GPU support DX11 and the settings on epic so It should work fine (It’s working great when it’s about 500 cm from a landscape…)

Is it known issue?
From google search I found some people with the same issue but with really old version of the engine…

*The landscape is only on the left side

I have seen a few minor bugs but never so many at once. Usually they go away for me if I fly the camera super far away and then back in. That causes it to rebuild the global distance field texture from scratch since it only stores it for a box around the camera.

I already tried that and also I tried to build the level and it’s doing the same thing…

What GPU do you have? There’s a bug with older AMD DX11 GPU’s (HD 6xxx) where they compute the global distance field wrong. In 4.15 DFAO is force disabled on those.

I haven’t seen that bug and I’m not sure what it is. However, we have changed the way landscape works with DFAO in 4.15, so maybe the bug will change too.

Dammit, I got HD5850 T_T
The weird part is that some UE4 games does use it with landscapes and it’s working as it should be…
For example Fortnite(Not sure if they even using landscapes but they do using DFAO…)
Also I downloaded some demo(not as source) that using DFAO with landscape and it does working.
So I tried packaging the game and it fixed the medium range, Close and far looks the same.

Anyway I really don’t think that does GPUs are the problem.
It’s seems like something wrong with the landscape.
And I wont be able to test it with 4.15 because it’s going to be disable :\

Is there a way to enable it?
Because I can work on it, It just wont work near landscapes for me…

For some reason it’s working fine when it’s under the landscape…
It’s like its projecting from the bottom up instead of from the top down :S

(The material returning the XYZ in RGB where the DFAO is working)

That is clearly the bug with landscape DFAO on older DX11 AMD cards as I mentioned. It’s really an AMD driver bug, but those old cards are end of life and not receiving further driver fixes.

I’d be tempted to agree, except I’m running into these ‘block’-artifacts on my GTX770 too. Or is this something else?

Seems like the same kind of artifact, at least.
Edit: After having seen this topic, I tried doing this stuff under my terrain with a bunch of cubes. Worked nearly flawlessly there. Any idea on what this would be? Again, GTX770, latest drivers.

Definitely something else if not on an old AMD card. What engine release are you on?

Can you come up with a simple set of steps to get it to happen that I can repeat? The only existing bug with the global distance field that I’m aware of, is that when you change maps the old map distance field may remain. You can erase it by moving the camera a long distance away and then come back. Does moving the camera away and coming back fix the bug in your case?

We’ve been having this same issue with inconsistent results. I’ve only seen it once on my GTX 970, but others on GTX 770 and 670 experience it consistently. Engine Version 4.13

Hey, sorry for leaving this thread for centuries. I just sort of gave up. I’ve now started using Distance Fields for water again, though, and it’s absolutely awful.
https://image.prntscr.com/image/WF3QiGvzSsu0IjyO8oeE9w.png (With terrain in level)
Steps for reproduction:

  1. Get a PC with a GTX 770 (I’m under the impression that only some GPUs have this issue).
  2. Make a material using Distance Fields
  3. Place a mesh in an object with said material
  4. See this result: Screenshot by Lightshot (Without terrain in the level)

As you can judge from the pictures, the issue is also actually worse when there’s a landscape in the level. As for moving in and out, the artifacts that exist in places where there’s no objects go away, but they also come back for no apparent reason. The square-ish stuff going on around objects is permanent and doesn’t go away no matter what I do.

You can have some impact on the DF by tampering the default settings. These are console commands and you will find a whole lot of them to tinkering with.

That is one of the many, and it have the biggest impact on the resolution which could help in some cases, but beware you can easily run out of GPU ram and the editor will crash. Save your work before changing the settings :slight_smile: It’s default value is 128.0 for me, but 192 can be a bit better in some cases.

Another handy one that can have huge impact on the result is the

By default it is 2.0 for me, but you can try values around this, eg 1.5, 2.5 and such. There are more settings too exists which may or may not produce differences but you will find them as the console command names quite similar, and the Output window will help you with finding them one by one.

You can also check up on the Global Distance Field visualizer in the editor viewport to see what is happening.

I have same problem with GeForce GTX 1060 with latest drivers.
And this hapend with all material (not only water). So I sure this is problem of Landscape distance fields.