Display turning off when using editor

Could be a gpu issue. Are you using nvidia, if so if shadow play on, this could result in the gpu trying to dump it memory to allow the next frame to be rendered, and then the display attempting to display that image before the next frame could be rendered.
Also try to reduce the resolution while the editor is running, and see how that runs.

When using any version of UE4 editor my screen turns on off for a few seconds and turns back on. Have restored windows and reinstalled UE4 by still happening. It only happens when UE4 is the program selected. I am using a 4k monitor and a hd monitor and its only happening on the 4k one. when using the editor on the hd monitor the 4k one still flickers.

I’m having this issue too. Also only on my 4K monitor. Turned off In-Game Overlay (which has replaced the Share option in Geforce) and it still happens. It’s also screwing with my sound card and switching my default audio device. Strange that this only started happening tonight when I’m trying to finalize a project…

you can in your sound options disable the options you don’t won’t and that will stop the switching (until an update happens, or never update the audio drivers after disable)

So i have figured out what the issue is. It’s to do with Nvidias latest driver 411.63 i rolled back to the previous driver and I am no longer getting this issue.

sound great, make that an answer separate from this comment thread, so people will know.

Issue is with Graphics Driver from Nvidia version 411.63 rolling back fixes this issue.

did updating to 411.70 cause an issue?

I too am having this issue with the new Nvidia drivers and a 4k monitor. Annoying as hell

I have the same problem ! …