Download

Displacement/Tessellation issue

Hi,

I’m trying to get my stone wall displaced a little bit but don’t see any effect no matter what values I input. The preview doesn’t change at all. I select the model in the Editor but it is not highlighted in wire frame mode after setting the Flat Tessellation on.

What am I missing to get it work?

Your normalmap has very little large scale variation (notice how the preview seems a single solid color). To visualize the maximum detail level you can achieve with tesselation you can temporarily turn on wireframe mode.

In general you want to use the normal map for small and medium scale surface detail and tesselation for larger scale detail. An example that would make sense with this material is to create a separate heightmap with random greyscale values per tile to get interesting height differences between the tiles.

I tried different textures and a model this time and it doesn’t still work. The imported model is very simple box, 200x200x200 cm, flat mapping UV. I tried two different settings plugged into the World Displacement. I’m not sure if the Tessellation Multiplier is working or not. In unlit mode I don’t see any difference when it has a value of 2. Usually when I select a model in the Editor the outline of the model is highlighted in orange color in the unlit mode but it is not in this case.

Any advice would be appreciated.

9b8d7e0002f969a6ecdb2b61f75d71c3b89ce887.jpeg

You should definitely see some tessellation there, so something else is wrong:

  • Are you sure you are running in DX11 mode?
    It won’t work in anything else. If you click play in new editor window or standalone game the feature level will be displayed in the title bar, make sure it says PCD3D_SM5.

  • Can you see tessellation on existing materials?
    For example in the content examples material map there are a couple of tessellated material, might be a good idea to test those.

Thank you for your reply, Arnage. I’ve been searching for DX11 thing but couldn’t find any info that shows how to set it up. I just played in New Editor Window, it says (64-bit/PCD3D_SM4). Does it have something to do with my graphics card? How can I set it to PCD3D_SM5? That’s totally new to me.

I don’t see tessellation on existing mats. Which ones are you talking about?
For example in the content examples material map there are a couple of tessellated material, might be a good idea to test those.

Yeah, in SM4 (directx 10) mode tessellation simply won’t work. You need a minimum of windows Vista (but that’s also required for SM4, so that’s not your issue) and a GPU that supports it, which you probably don’t have considering Unreal defaulted to SM4 mode.

I see, so I need to invest for my hardware now, been using Nvidia Quadro series but hear people say GTX is good. If you know anything, which one would you recommend? I use UE4 for ArchViz, walk through, animation, etc.

Quadro cards are quite nice for certain applications, but in general they are not worth the extra cost when working with game engines. (However, considering your field you might want one for the benefits they offer in applications such as AutoCAD)

Overall though your card is probably a bit older already as quadros have had support for SM5 for a while now, so regardless of your choice you’ll probably see a performance boost.

I know this is a old post, but have the same issue and find this in google. So i will help others have the same problem.
There is a bug in the landscape if a user enables ‘Crack Free Displacement’: Unreal Engine Issues and Bug Tracker (UE-38815)

And also, if you use Basic Meshes, like “Box” from the “Modes” menu, displacement materials wont work. So just make a box in your favorit 3D Application, subsurface the faces and import to UE4 to get it worked :wink:

Cya, Sam

I don`t know if it helps BUT it did for me! i Tryed everything and still getting wrong displacement. GO DO THE MESH, EDIT MESH, SEARCH “REMOVE DEGENERATES” AND MARK IT! THATS IT!!! Of course, you have to properly config the displacement on the material, but now it will \o\

Remove Degenerates thingy: Screenshot-11 — ImgBB
Screenshoot as example(i exagerated, of course): Screenshot-12 — ImgBB
My config for the Displacement on the material: Screenshot-13 — ImgBB

Bump?

I’m having a similar issue. As you can see, the preview shows displacement taking place but the actual texture in game has no change. What gives?

Tessellation works by sub-dividing the mesh to get a dense mesh that can be displaced. This only works if there is a mesh that is suitable to sub-divide (hence the ‘remove degenerates’ having an effect in the post above).

What works for me, is to use a mesh that is having some reasonable, regular, mesh density to start with. So you need to make sure it’s having more-or-less regular triangles. For example, if you’re using a floor that you want to displace, I try to use a base mesh with vertices every meter or so (instead of a ‘minimal’ mesh that fits the space precisely).

I get that but even when I use 'suitable meshes" I have unfavorable results. AND I’ve watched this Mega Scan tutorial where the guy does this on a basic plan and it worked perfectly https://www.youtube.com/watch?v=1GkS9-94k80&t=332s My setup is the same and I’ve made several attempts using different textures, displacement maps, and objects. The above one is meant to be a floor but this pillar didn’t turn out much better. I’ve had constant problems with displacement maps in Unreal. I bake them out from ZBrush and I’ve tried both methods for that as well.

As you can see, some of the detail comes in but other details are jagged.

I think for the ground, the map just isn’t strong enough and the plane just isn’t subdivided high enough. I’ll keep adjusting them but honestly at this point when a plane has to be 10k polygons what am I really gaining by using this technique? The pillar is 50k polygons before the displacement is applied. I suppose once UE5 comes out, this whole fiddling with displacements will be a thing of the past.