Displacement problem using Quixel materials

As you can see on first screenshot displacement is good and texture is not flat anymore even is looking good when i put it on plane. But when i try to use this material on plane that is placed in the world then mesh is looking really bad and texture is totally flat. I would be grateful when someone could help me.

Picture 1:

Picture 2:

Picture 3:

Based on the jagged polyons and the vector displacement-tag, the reason it looks bad is you simply lack enough polygons ”in the real world meshes” to have detail. Either increase consistent polycount, or use parallax occlusion mapping instead of vertex offset.

But Quixel made tutorial about working with displacement and in this tutorial they put texture on default UE4 plane and texture is looking good. I tried do same thing but you saw my results and i try to understand what happend that for them it’s working perfectly and for me is not with same settings.
Here is a link to tutorial:

They have tesselation enabled - all the geometry gets more polygons generated based on how far away it is.