Download

Disabling the GBuffer/Forward Rendering

I don’t have anything in particular that I’m working on but I was investigating scalability options in Unreal Engine and found the r.GBuffer option in [/Script/Engine.RendererSettings] group. Upon using it all of my surface materials become black, but the framerate skyrockets, so I assume it is actually using a forward rendering path.

Has anyone had luck getting this to work? What are the caveats? I would imagine this is the best route to go for games using Paper2D, but leveraging it as a total fallback option for systems that have slow framebuffers (Intel graphics in particular) would be nice too. With the black surfaces it seems completely broken, though.

Hi Furyhunter, not specifically sure about that cvar, but for mobile we render using the forward renderer; you can enable it in the editor, or if you run your game with -game you can add -featureleveles2.