Disabling Reflections of Specific Meshes

How do I go about disabling the reflections of specific meshes?
I have stars that are millions of km away from a planet or moon that the player is on but there are reflections of the stars on every object.
This happens with both Lumen and Screen Space (beta) Dynamic Global Illumination methods. In the images below I’m using Screen Space GI.

In this image you can see the reflections of the stars on the UE5 Manny:

Here you can see the zoomed reflections of some stars in the water:

You can actually enable whether or not an object shows up in dynamic GI/reflections, but it doesn’t work on screen-space. Screen-space will simply reflect whatever the depth buffer is rendering, and there’s no easy way to work around it to my knowledge. I am happy to be proven wrong.

On the mesh there is a setting you can toggle, “Visible in Reflection Captures”

I’m not sure it applies to the skylight capture though, but its worth a shot.

Thanks @Arkiras.
Unfortunately reflections are still showing for both Lumen and Screen Space GI.

@jblackwell Thanks. That makes sense. I’ll keep looking into it while Lumen is set.

Do you have lights associated with these meshes? Because it looks like the specular reflection of a light, not a mesh

They are just Nanite spheres with emissive materials.