Disable uv scrolling on trail particles, possible?

Im trying to create a smokey effect for my shooting, but im trying to keep it stylised.
I have a trail particle which leaves a trail, but its scrolls the texture along with the movement of the particle system.

Is there a way to keep the uv’s static? So the texture repeats?

Fortunately, yes there is! Ribbon Trails have two sets of UV’coordinates, so if you set the ‘Tex Coord’ nodes in your material to use Index 1, it should stay put on the trail.

You might also want to create the UV’s based on World Position. Theres a smoke-trail particle in Content Examples that has a material to show you exactly how you do that. I used a similar technique for these:

Wow, are you working on battlezone in the ue4 engine?? That is awesome! Long time fan!

Thanks for that, ill check out the settings :slight_smile:
I tried the other method and found it lacking for what i needed.

Edit: found theres a setting in the particle needed too. Thanks!