Download

disable self-shadowing

Hello!

I am a houdini artist and I am new to unreal. I am trying to get a diffuse-like look for different objects in my scene including some foliage. I don’t want the objects to cast shadows on themselves, but I want them to be able to receive shadows from other objects. For example, I don’t want my grass to cast shadows on it self but I want it to receive shadows from a wall. I saw a post like this saying to plug my texture into emission rather than base color. That does give me the look I want, but it wont receive shadows from other objects because it is emissive. How can I disable self shadowing on static objects and how do I do this on foliage? Is it something I should do on the material?

Thanks

I found a solution! There are 2 easy ways to get a flat texture. color in emission is the first method. The problem is the material cant have shadows on it from other objects because it is emissive. The other way is to set the normals on the material to 0,0,0. The problem with that method is that any part of the object in the shadow is completely black. So i combined the methods. I started off my setting the normals to 0,0,0, but then I also added my color map into the emission, and multiplied it by 0.2. the emission part will brighten the area in the shadow so its not 100% dark.

interesting that it was solved by a combination of those…it might also work to use a Linear Interpolate between color-emission and normal-000. Then parameterize it to get immediate access to the new property, and save it as a material by itself or as a stack of material properties to use it on any other objects and not need to recreate it for every material using it for.