Disable "receives decals" on Procedural Mesh Component

I’m trying to set “bReceivesDecals = false” in runtime on a ProceduralMeshComponent, I’m also calling MarkRenderStateDirty() after that (same as in DestructibleComponent.cpp[679]) but the decal is not turning off.

I see that the Receives Decals checkbox is turned off on the editor but the decal is still visible on the mesh.

Is there anyway to fix this?

I’m on 4.10, seeing this behavior on windows but I need this functionality on mobile too. Thank you.

Well thanks for mentioning that you need to call MarkRenderStateDirty(). I was toggling decals and wondering why they weren’t working.

I have the same problem,how do you solve it?

I have the same problem,
then set material to procedure mesh,
the decal will missing.