Disable plugins outside of editor?

Hi there,

I tried installing a plugin (vaRest) last night and now my project won’t open. When I try to, it says the project module needs to be recompiled. When I recompile, it says it couldn’t be recompiled. If I try to start the game anyway, I get some spiel about the plugin not being compatible with my engine version and needing to be recompiled but the recompile fails so I don’t know how to proceed. If I delete the vaRest folder from my plugins, the launcher tells me that the project needs the varest plugin, even though I’ve used none of the nodes offered by the plugin since I haven’t even been able to start the editor!

As great as varest is, I’d really rather be able to continue working on my project. I’ve combed through the files, configs, and logs in my project folder and deleted any instance of varest-related things but I can’t get past this error. Since I can’t start the editor for this project, is there a way to disable plugins without the use of the editor?

Oh good God, thank you for that.
In case anyone is in the same boat I was, here’s a walkthrough:

Go to your project folder, i.e. "C:\Users\Documents\Unreal Projects\YourGame\ and right click on “YourGame.uproject.” Open With Notepad. Inside the file you’ll see plugins listed in braces and separated by commas. Just delete the entry in braces you want to disable and the comma after it. Don’t delete any square brackets or other pieces, just the braces, the comma, and the plugin information inside the braces.

2 Likes

There is a .uproject file for your project. In there is the list of plugins that you have enabled for your project. Find and delete the entry related to vaRest. That should fix it

1 Like

I was, thank you. Can play around again.

I did not edit it because of the ICON. LOL

Narg

Great post. Is it possible to remove references to unused plugins from the complied gz html files? I installed substance briefly and removed, however I only just found this solution after i’ve packaged for html 5 and the missing plugin is stopping it from working.

Cheers

Pretty sure there isn’t a way after it has been packaged

no worries Joe thanks. I’ve got bigger problems at the moment.

unable to expand memory error and:

LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_1b4c_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_a9c4_0///####STATCAT_Advanced####

Unreal packaging for html is like rocket science…I expected if it all worked fine for windows etc then to get it working for html5 would be a simple case of packaging for html5 and then sticking it on a compatable server… instead it’s errors galore even locally :S

I haven’t packaged for HTML in quite sometime. The first time I got everything setup, it was a bit on the painful side. Wish the process was easier.

Yeah, starting to think it would actually be easier for me to start building the architectural piece in the real world…using marbles.

Joe, I tried applying your advice to a similar situation, but didn’t take, if you could steer me. I build from source code in Visual Studio 2013, at Debug new instance I get

70535-project_out_of_date.png

Project out of date message. When I okay rebuilding, I get

70536-oculus_audio.png

the issue which led me to searching/finding your solution, which clearly doesn’t apply in my case. I opened .uproject into Notepad and removed any references to Oculus and saved, debugged again, same results. Thanks if you can make sense of it.

I’m also attaching an Output Log of the build that originally caused me to change target from Development Editor to Development, based on advice from another post. [link text][3] Perhaps, it’s also relevant here.

Many thanks for your time!

Try regenerating your project after removing the plugin. The project generation adds in the plugin dependencies, so a rebuild is probably needed. I think I’ve done that in the past.

Bummer. I was hoping that was it. One last thing is to delete your project’s intermediate folder. I’ve had a few occasions where stale items mucked things up. It doesn’t happen very often, but sometimes this can help

By “regenerate” I take that to mean run GenerateProjectFiles.bat again to build a new UE4.sln, yes? I did that, but when I open and Build, it seems the previous build is still being seen, as it only took seconds to build and usually it’s around 45 minutes. And when I then Debug new instance, I get the same two messages as before, Project being out of date and not being able to find the OculusAudio plugin. Where might I be going off map?

Thanks.

Thanks Joe. I’ll try it, simply delete Intermediate folder from project, then jump straight to Debug new instance?

It appears I might have wandered off track, chasing down one problem seemed only to invite new problems. Originally I was in VS 2013, successfully ran Build after editing the FFakeStereoRendering class, and successfully was able to Debug new instance to launch project into Editor using this revised build. I run into the problem packaging with the Missing UE4Game binary.

  1. I read about the target in VS needing to be set to Development, not Development Editor, though it’s unclear which VS defaults to, as the cell is to small and phrase is truncated and drop down menu doesn’t show which was highlighted. I select Development, run Build, which is when I get the idea nothing new has happened since it showed up with successful Build in seconds. Debug brings up these two messages about Project being out of date and then the OculusAudio plugin being missing. These are now new issues, and yet if I open the uproject file pointing to the revised engine, I still get the same errors as before, five yellow warnings about various maps not found and the same red show stopper about UE4Game binary Missing.

I’m recounting all this to see if it helps provide you more insight. One thought is to delete UnrealEngine-release and start that whole process over. Open the project in 4.10.01, delete the “other” version pointing to the revised engine and clear that slate as well. Yes? and if so, is my understanding of workflow on track here for implementing the revised engine to package my demo:

  1. run Setup.bat
  2. ren GenerateProjectFiles.bat
  3. launch UE4.sln
  4. select Development Win64 in target
  5. Right-click UE4 in right pane, select Build, save.
  6. Right-click UE4 in right pane, select Set as Startup project
  7. Right-click UE4 in right pane, select Debug, Start new instance
  8. Editor launches, package for Windows 64-bit

Thanks for your help.

Development/Shipping/Debug is for a standalone version of the game with no editor components compiled in. You need to use Development Editor.

Okay, glad I shared all that. Assuming I now change this to Development Editor, I then right-click UE4 select Rebuild? Is this the same as selecting from the Build menu? Anything else in my workflow that looks off? Thanks, again.

Everything else looks right to me.

So, I’m at least back to where I was with only the Missing UE4Game binaries message while packaging in Editor. Rebuidling in VS 2013 and targeting Environmnet Editor Win64 I got the same message about project needing to be updated, but no longer the one about OculusAudio plugin, at least that, and it launches Editor, so that’s good. I’m attaching the last bit in the Output Log showing the yellow and red badnesses. Any idea how I resolve the yellows, Unable to find NewGameMode and those various Maps? And yet the Missing UE4Game binary…

I do appreciate your help.

Hello Joe,

I’m still wrestling this beastie, got a tip from a friend who claims this Error Missing UE4Game binary issue relates to a reference needing to be set in Visual Studio telling it to reach out for the correct library referenced by UE4 binary. I couldn’t completely follow his advice and he was on a car phone so couldn’t see the GUI, but talked me through the following: Right-click on UE4 while the UE4.sln is open in VS; select Properties, open Common Properties, select References, click Add New Reference…, a long list pops up, this being where he couldn’t direct me any further. Any thoughts about this route?

Thanks.

You need to build the binary too. So make sure you build both Development Editor and Development for your target platforms