Disable Pitch

Hi - in the game character blueprint its possible to disable the mouse and gamepad pitch/lookupRate so that the player can only look around horizontally rather than tilting the camera vertically.
How can the same be achieved with the Rift and where is the blueprint located where it can be adjusted ?
I’ve created a 3rd person game but the Rift causes too much freedom with the camera whereby the viewer can look down on the avatars head and also look beneath the avatars feet.
Any advice would be great.

its a nice idea do at leat the basic bp tutorials in the Epic youtube and then ask your doubts, not before.

Go to Project Settings, Inputs and under the Axis series, try deleting LookUpAxis.

Hope this helps!

Hi Haruna - thanks for your advice.
What you suggested works fine for mouse control but has no impact over the Rift control.
Is there anyway that the Rift plugin settings can be opened in Unreal and the lookup axis mapping be unlinked to it ?

You can check “Is HMD connected?” and then branch in the LookUp and LookUpRate functions if it is and do nothing.

Thanks I’ll check that after Christmas

Hi - I looked for “Is HMD connected?” but its not an option in my blueprint editor. I’m using v4.9.0.
I’ve attached a screenshot of the options available.
Any ideas ?dc0f290255653561b237d642aeac84f38b45fb2c.jpeg

Hi - I fixed the issue using the following tutorial: