Disable Motion Blur for Translucent Material

Hello there,

how do i disable the Motion Blur effect on a translucent material in front of a camera, e.g. glass material on mask mesh.

This is quick test on how it looks in game:

I don’t want to disable motion blur all together, this is not a solution. Other games like Metro do this as well so there must be another solution to this. Any ideas?


bump. no one knows an answer to this?

Motion blur is not something that you can enable or disable on per-object basis. Newer engine versions have a checkbox on translucent materials, allowing velocity writes, which may or may not help you. But overall, the answer you are looking for is that you can’t.

1 Like

Yes, thank you, this seems to be a solution. In UE4.23+ there is an option inside the material.
But for this i need to upgrade my project to a new version. I guess for older versions you need to add velocity data for transparent materials in source code.

Thanks, can confirm this is a 100% fix for this issue, had the same problem and now it is gone.

This tutorial helped me with a similar issue.

1 Like

Setting Translucency Pass to After Motion Blur fixed this problem for me.


Want to add that I’m on 4.27 and checking Output Velocity under Translucency worked for me.

1 Like

Thanks guys, this helped me a lot! <3

How to fix always draw top :worried:

Change “Output depth and velocity” to true in material. Work ideal for me in UE5.3 for translucent material, when motion blur is enabled in project settings.