Disable eye adaptation in game.

I think you can use PostProcessVolume to do that. First add one to your scene, then in its details, go to Lens → Exposure and apply Min EV100 and Max EV100 and set them both to 0.

I’m making a test game in 2D because i’m begginer, in viewport i disable all Post-processing effect. But in game it doesn’t take effect.
I especially want to disable the eye adaptation.
Thanks and see you!

In Project Settings, search for Auto Exposure and disable it

try making a new level with the blank level template, then make a little room and see if the eye adaptation still happens.

If it doesn’t happen on the blank level, then you know the problem is happening somewhere on the level you created and not the engine

and make sure you disabled it in project settings too

I tried both of your answer but nothing works :confused:

I would disable the eye adaptation because it make this effect in game: (screenshot 1)
Instead of this in viewport: (screenshot 2)
I hope it help you.

is someone have the answer?

Select your Camera Component, and in the Details panel go to Post Process>Lens>Exposure, and then check the boxes besides “Metering Mode” and “Exposure Compensation”. Then, set the Metering Mode to “Manual” and adjust the Exposure Compensation to set the effective brightness of the result.


Hope this helps!