Directional light with shadows black on mobile

Hello,

staff member Tim Hobson told me to post this in a new thread.
My Problem is the following. I need shadows on MOBILE for a prototype. As I read, they should be supported with a movable directional light since 4.5.
As soon as I have the directional light and it casts shadows - all my objects go black in the mobile preview and on android devices. In the editor - everything is completly overexposed.

the material has a texture, metallic set to 1 and roughness around 0.3 (just as additonal information)

They seem to be extremly dark because I’m still able to see a little of the texture

addtion: I tested with a just white material and I see more of the object. but its not what it should look like - shadows are unexpected and absolutely no reaction to other lights in mobile preview if a directional light is there (spot or point light - no matter if static, stationary or movable).

any advice or help someone?

Hi,
As far as I can tell this seems to be a bug.
I had the same question myself here;

and another user with a similar problem here;

https://answers.unrealengine.com/questions/110655/45-preview-shadow-issue-on-mobile.html

He did seem to have an ambient value on android using a skylight but it didn’t work on ios.

I also had the same findings as you where the dynamic light in the scene effectively removes all other static or stationary light contribution. Even world environment color is cancelled out.
The suggestion was to turn on HDR for mobile but that didn’t work for me.

Try it again in android with a skylight or just turning the environment color up to 128 (the default is black). The user in the link above (hls333555) has a nice result on android. I imagine you could just keep on developing and it will get fixed at some point :slight_smile:

I managed to get this working in the mobile preview and on the Ipad.
See the thread here and look for my answer.

https://answers.unrealengine.com/questions/110655/45-preview-shadow-issue-on-mobile.html