Download

Directional Light (Sun) not rotating in build

I’ve been building a game using the BP Sky Sphere for a simple day/night cycle, which has worked perfectly until now. The last time I built the game, it worked perfectly, after adding some resolutions to my custom settings menu, suddenly when I build the game the directional light no longer rotates in the built version of the game, it stays locked facing directly downwards even as time goes on.

The strange part is that it still works fine in engine, it rotates properly and changes the sky colour according to the time of day. Even stranger still, I brought the exact same build over to my old computer, and the directional light worked as expected on my old computer. Same exact build, different computer; completely different directional light behavior.
Does anyone know what’s going on here?

EDIT: I should also add I’ve brought previous versions of the game onto this computer, and the same problem occurs now, in versions where I’ve never seen it before.

Update: I can confirm other computers do not experience this error in the same exact build. So it seems to be a problem that’s only happening on this machine, therefore I can continue to develop my project, I’m just worried other users with similar hardware set ups may run into the same problem. If anyone can think of a reason this may be happening, it would help a lot.

Only thing I can think of is that your level blueprint is not ticking. Could be due to a memory error of some sort.

If your build is in debug mode you can probably figure this out by adding a print string to the sun rotation counter.

A quick fix might also be to delete the various folders within the project and let unreal re-build all the shades and folders.

Assuming ofc. That the issue isn’t somehow the way you created the sun rotation system. It could be that its progressing at different speeds because of the tick speed being different on different machines…

I appreciate the suggestions, I’ll try deleting the Intermediate and Build folders and see if that helps anything.

Remember that this is a project where the sun was working perfectly until recently, nothing was changed with the coding of the sun or sky sphere, and it still functions perfectly on other machines, and in the editor mode, meaning there’s no way it could be the blueprinting. Also, every other function in the level blueprint still fires, and all sun rotation is tied to delta time. I’m almost positive it’s a hardware problem.