Directional Light is visible in closed area

Hello. I’m quite new in Unreal and can’t find the anser.
I’m trying to make some kind of sci-fi interrior in space. Directional light is simultating the star far away. Picture 1.
But the thing is light is also visible inside completely closed area - Picture 2.
How can it be fixed?
Static meshes which are used to make interrior doesn’t have polygons on the back to reduce polycount. Can it be the reason? If so, is there a way not to let Directional Light affect inside without adding polygons?

There might be a way to do this with tweaking parameters, but I don’t think so ( I’d love to hear it if there is ).

You basically have to box the whole thing in cubes. You can just not show the cubes from the outside ( of course ), and only use them when you’re inside.

It might be possible to do something with the ‘cast hidden shadow’ mesh parameter ( I think it’s called ).

1 Like

Hey @olgerdknight! Welcome to the Forums!

Out of curiosity, on your static meshes have you tried having Shadow Two Sided checked as a setting? This will allow you to cast shadows as if both sides have polygons. Check out this example using a one sided plane:

Hopefully the above is the solution you need!


Thanks everyone!
For now Shadow Two Sided worked fine. Scene will need some other tweaks like cubes too, but at least the way is clear now :smiling_face:

1 Like